Versions less than 0.0.6 of the Node.js stringstream module are vulnerable to an…
Priority LOW 35CWE-125Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Versions less than 0.0.6 of the Node.js stringstream module are vulnerable to an out-of-bounds read because of allocation of uninitialized buffers when a number is passed in the input stream (when using Node.js 4.x).
Why it matters now
EPSS 0.03682 89th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed stringstream (npm): 0.0.6Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | stringstream (npm) | before 0.0.6 | 0.0.6 | Patch available | GHSA-mf6x-7mm4-x2g7 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- stringstream (npm) Vendor— Affected before 0.0.6 Fixed in 0.0.6 Patch available GHSA-mf6x-7mm4-x2g7
Remediation
- Fix · GHSA-mf6x-7mm4-x2g7 stringstream (npm) Fixed in 0.0.6 Advisory →
Red Hat 1 advisory
- RHSA-2021:3917 Released 2021-10-19 · Red Hat rating ImportantRed Hat Quay v3.6.0 security, bug fix and enhancement update
- Quay v3 quay/quay-rhel8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Quay v3 | Fixed | RHSA-2021:3917 |
Not affected: 3 products
- Quay v3
- Red Hat OpenShift Container Platform 3.11
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2018-21270
- 2026-10-03 Alias added: GHSA-mf6x-7mm4-x2g7
References
More NodeJS Node.js vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
- TI-2022-03315 X.509 Email Address 4-byte Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2018-21270 · CVE Program
- CVE-2018-21270 · NVD
- FIRST EPSS
- GHSA-mf6x-7mm4-x2g7 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-21270 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences