Read the docs
TI-2018-15246 Aliases CVE-2018-25019GHSA-vvx7-4gw3-r3mv

LearnDash < 2.5.4 - Unauthenticated Arbitrary File Upload

Priority LOW 36CWE-434Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution, Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-434 and CWE-862.

Summary

The LearnDash LMS WordPress plugin before 2.5.4 does not have any authorisation and validation of the file to be uploaded in the learndash_assignment_process_init() function, which could allow unauthenticated users to upload arbitrary files to the web server

Why it matters now

EPSS 0.01581 75th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed LearnDash LMS (Unknown): 2.5.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownLearnDash LMS2.5.4 to before 2.5.42.5.4Patch availableCNA
  • LearnDash LMS VendorUnknown Affected 2.5.4 to before 2.5.4 Fixed in 2.5.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:learndash:learndash:*:*:*:*:*:wordpress:*:*up to 2.5.4VulnerableLearnDash
  • cpe:2.3:a:learndash:learndash:*:*:*:*:*:wordpress:*:* Versions up to 2.5.4 Vulnerable ·LearnDash

Remediation

  • Fix · CNA LearnDash LMS (Unknown) Fixed in 2.5.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-25019
  2. 2026-10-03 Alias added: GHSA-vvx7-4gw3-r3mv

References

  • TI-2024-01123 LearnDash LMS <= 4.10.2 - Sensitive Information Exposure via API CVSS 3.1MEDIUM 5.3
  • TI-2024-37710 LearnDash v6.7.1 was discovered to contain a stored cross-site scripting (XSS)… CVSS 3.1MEDIUM 5.4
  • TI-2024-37709 LearnDash v6.7.1 was discovered to contain a stored cross-site scripting (XSS)… CVSS 3.1MEDIUM 5.4
  • TI-2024-01125 LearnDash LMS <= 4.10.1 - Sensitive Information Exposure via API CVSS 3.1MEDIUM 5.3
  • TI-2020-04910 LearnDash Wordpress plugin version below 3.1.6 is vulnerable to Unauthenticated SQL Injection. CVSS 3.1CRITICAL 9.8
  • TI-2023-02910 LearnDash LMS <= 4.6.0 - Authenticated (Subscriber+) Insecure Direct Object Reference to Arbitrary User Password Change CVSS 3.1HIGH 8.8
See all 10 →

Sources