Read the docs

Improper input validation bugs in DNSSEC validators components in PowerDNS version 4.1.0…

Priority LOW 20CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
None · None · Low
Fix status
No fix listed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA.

Summary

Improper input validation bugs in DNSSEC validators components in PowerDNS version 4.1.0 allow attacker in man-in-the-middle position to deny existence of some data in DNS via packet replay.

Why it matters now

EPSS 0.01287 70th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:powerdns:recursor:4.1.0:*:*:*:*:*:*:*4.1.0VulnerablePowerDNS
  • cpe:2.3:a:powerdns:recursor:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·PowerDNS

Remediation

No fixed version listed by the sources yet.

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000003
  2. 2026-10-03 Alias added: GHSA-vm3q-6vgq-8qhr

References

  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
  • TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
  • TI-2017-11091 NULL pointer dereference in PowerDNS pdns-recursor CVSS 3.0HIGH 7.5
  • TI-2014-07065 PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote… CVSS 2.0MEDIUM 5.0
See all 49 →

Sources