Imagely NextGEN Gallery version 2.2.30 and earlier contains a Cross Site Scripting (XSS)…
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Imagely NextGEN Gallery version 2.2.30 and earlier contains a Cross Site Scripting (XSS) vulnerability in Image Alt & Title Text. This attack appears to be exploitable via a victim viewing the image in the administrator page. This vulnerability appears to have been fixed in 2.2.45.
Why it matters now
EPSS 0.00564 47th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000172
- 2026-10-03 Alias added: GHSA-7p4h-vc8v-w2w2
References
More Imagely Nextgen Gallery vulnerabilities
- TI-2023-02956 NextGEN Gallery < 3.39 - Admin+ PHAR Deserialization CVSS 3.1HIGH 7.5
- TI-2019-10666 A SQL injection vulnerability exists in the Imagely NextGEN Gallery plugin before 3.2.11… CVSS 3.0CRITICAL 9.8
- TI-2023-02957 NextGEN Gallery < 3.39 - Admin+ Arbitrary File Read and Delete CVSS 3.1HIGH 7.2
- TI-2024-05058 NextGEN Gallery < 3.59.3 - Admin+ Stored XSS CVSS 3.1MEDIUM 5.9
- TI-2013-03217 NextGEN Gallery plugin before 1.9.13 for WordPress: ngggallery.php file upload CVSS 3.1CRITICAL 9.8
- TI-2024-02901 WordPress Gallery Plugin – NextGEN Gallery <= 3.59 - Missing Authorization to Unauthenticated Information Disclosure CVSS 3.1MEDIUM 5.3
Sources
- CVE-2018-1000172 · CVE Program
- CVE-2018-1000172 · NVD
- FIRST EPSS
- GHSA-7p4h-vc8v-w2w2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences