Cisco HyperFlex Software Cross-Frame Scripting Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass, Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-693 and CWE-1021.
Summary
A vulnerability in the web-based interface of Cisco HyperFlex Software could allow an unauthenticated, remote attacker to execute a cross-frame scripting (XFS) attack on an affected device. This vulnerability is due to insufficient HTML iframe protection. An attacker could exploit this vulnerability by directing a user to an attacker-controlled web page that contains a malicious HTML iframe. A successful exploit could allow the attacker to conduct clickjacking or other clientside browser attacks.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco HyperFlex HX-Series | before 3.5.2f | 3.5.2f | Patch available | CNA |
- Cisco HyperFlex HX-Series VendorCisco Affected before 3.5.2f Fixed in 3.5.2f Patch available CNA
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:*:*:*:*:*:*:*:* | up to 3.5.2f | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* | 4.0(1a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx220c_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:*:*:*:*:*:*:*:* | up to 3.5.2f | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* | 4.0(1a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx240c_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:*:*:*:*:*:*:*:* | up to 3.5.2f | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* | 4.0(1a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx220c_af_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:*:*:*:*:*:*:*:* | up to 3.5.2f | Vulnerable | Cisco |
- cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:*:*:*:*:*:*:*:* Versions up to 3.5.2f Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* Versions 4.0(1a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx220c_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:*:*:*:*:*:*:*:* Versions up to 3.5.2f Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* Versions 4.0(1a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx240c_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:*:*:*:*:*:*:*:* Versions up to 3.5.2f Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* Versions 4.0(1a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx220c_af_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:*:*:*:*:*:*:*:* Versions up to 3.5.2f Vulnerable ·Cisco
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* | 4.0(1a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx240c_af_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:*:*:*:*:*:*:*:* | up to 3.5.2f | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* | 4.0(1a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx220c_edge_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* Versions 4.0(1a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx240c_af_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:*:*:*:*:*:*:*:* Versions up to 3.5.2f Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* Versions 4.0(1a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx220c_edge_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Remediation
- Fix · CNA Cisco HyperFlex HX-Series (Cisco) Fixed in 3.5.2f
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Cisco HyperFlex HX-Series 3.5.2f
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-09421 Cisco HyperFlex Software Counter Value Injection VulnerabilityPriority LOW 31
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1975
- 2026-10-03 Alias added: GHSA-hxvj-9m68-2v8w
References
More Cisco Hyperflex Hx220c Af M5 Firmware vulnerabilities
- TI-2019-09422 Cisco HyperFlex Static SSL Key Vulnerability CVSS 3.1HIGH 7.4
- TI-2019-09421 Cisco HyperFlex Software Counter Value Injection Vulnerability CVSS 3.1MEDIUM 5.3
Sources
- CVE-2019-1975 · CVE Program
- CVE-2019-1975 · NVD
- FIRST EPSS
- GHSA-hxvj-9m68-2v8w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences