Cisco HyperFlex Software Counter Value Injection Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-345.
Summary
A vulnerability in the statistics collection service of Cisco HyperFlex Software could allow an unauthenticated, remote attacker to inject arbitrary values on an affected device. The vulnerability is due to insufficient authentication for the statistics collection service. An attacker could exploit this vulnerability by sending properly formatted data values to the statistics collection service of an affected device. A successful exploit could allow the attacker to cause the web interface statistics view to present invalid data to users.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco HyperFlex HX-Series | before 3.5.2f | 3.5.2f | Patch available | CNA |
- Cisco HyperFlex HX-Series VendorCisco Affected before 3.5.2f Fixed in 3.5.2f Patch available CNA
CPE configurations NVD · 20
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* | 3.0(1a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* | 3.5(2a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* | 4.0(1a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx220c_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* | 3.0(1a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* | 3.5(2a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* | 4.0(1a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx240c_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* | 3.0(1a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* | 3.5(2a) | Vulnerable | Cisco |
- cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* Versions 3.0(1a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* Versions 3.5(2a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* Versions 4.0(1a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx220c_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* Versions 3.0(1a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* Versions 3.5(2a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* Versions 4.0(1a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx240c_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* Versions 3.0(1a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* Versions 3.5(2a) Vulnerable ·Cisco
Show 10 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* | 4.0(1a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx220c_af_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* | 3.0(1a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* | 3.5(2a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* | 4.0(1a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx240c_af_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* | 3.0(1a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* | 3.5(2a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* | 4.0(1a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx220c_edge_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* Versions 4.0(1a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx220c_af_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* Versions 3.0(1a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* Versions 3.5(2a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* Versions 4.0(1a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx240c_af_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* Versions 3.0(1a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* Versions 3.5(2a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:4.0\(1a\):*:*:*:*:*:*:* Versions 4.0(1a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx220c_edge_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Remediation
- Fix · CNA Cisco HyperFlex HX-Series (Cisco) Fixed in 3.5.2f
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Cisco HyperFlex HX-Series 3.5.2f
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-01595 Cisco HyperFlex Software Cross-Frame Scripting VulnerabilityPriority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2019-12620
- 2026-10-03 Alias added: GHSA-33f4-9hr4-253g
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
More Cisco Hyperflex Hx220c Af M5 Firmware vulnerabilities
- TI-2019-09422 Cisco HyperFlex Static SSL Key Vulnerability CVSS 3.1HIGH 7.4
- TI-2019-01595 Cisco HyperFlex Software Cross-Frame Scripting Vulnerability CVSS 3.1MEDIUM 6.1
Sources
- CVE-2019-12620 · CVE Program
- CVE-2019-12620 · NVD
- FIRST EPSS
- GHSA-33f4-9hr4-253g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences