Cisco HyperFlex Static SSL Key Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-327.
Summary
A vulnerability in Cisco HyperFlex Software could allow an unauthenticated, remote attacker to perform a man-in-the-middle attack. The vulnerability is due to insufficient key management. An attacker could exploit this vulnerability by obtaining a specific encryption key for the cluster. A successful exploit could allow the attacker to perform a man-in-the-middle attack against other nodes in the cluster.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco HyperFlex HX-Series | before 4.0(1a) | 4.0(1a) | Patch available | CNA |
- Cisco HyperFlex HX-Series VendorCisco Affected before 4.0(1a) Fixed in 4.0(1a) Patch available CNA
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* | 3.0(1a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* | 3.5(2a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx220c_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* | 3.0(1a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* | 3.5(2a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx240c_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* | 3.0(1a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* | 3.5(2a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx220c_af_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* | 3.0(1a) | Vulnerable | Cisco |
- cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* Versions 3.0(1a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* Versions 3.5(2a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx220c_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* Versions 3.0(1a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx240c_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* Versions 3.5(2a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx240c_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* Versions 3.0(1a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_af_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* Versions 3.5(2a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx220c_af_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* Versions 3.0(1a) Vulnerable ·Cisco
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* | 3.5(2a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx240c_af_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* | 3.0(1a) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* | 3.5(2a) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:hyperflex_hx220c_edge_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:o:cisco:hyperflex_hx240c_af_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* Versions 3.5(2a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx240c_af_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:3.0\(1a\):*:*:*:*:*:*:* Versions 3.0(1a) Vulnerable ·Cisco
- cpe:2.3:o:cisco:hyperflex_hx220c_edge_m5_firmware:3.5\(2a\):*:*:*:*:*:*:* Versions 3.5(2a) Vulnerable ·Cisco
- cpe:2.3:h:cisco:hyperflex_hx220c_edge_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Remediation
- Fix · CNA Cisco HyperFlex HX-Series (Cisco) Fixed in 4.0(1a)
Timeline
- 2026-10-02 Threatist record created from CVE-2019-12621
- 2026-10-03 Alias added: GHSA-mghj-97x2-4v8w
References
More Cisco Hyperflex Hx220c Af M5 Firmware vulnerabilities
- TI-2019-09421 Cisco HyperFlex Software Counter Value Injection Vulnerability CVSS 3.1MEDIUM 5.3
- TI-2019-01595 Cisco HyperFlex Software Cross-Frame Scripting Vulnerability CVSS 3.1MEDIUM 6.1
Sources
- CVE-2019-12621 · CVE Program
- CVE-2019-12621 · NVD
- FIRST EPSS
- GHSA-mghj-97x2-4v8w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences