Read the docs
TI-2019-02745 Aliases CVE-2019-3726GHSA-c3v3-2rrj-72gc

Uncontrolled search path in Dell EMC Servers: Networking and Fibre Channel Drivers: Dell…

Priority LOW 30CWE-427Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
Required
Attack complexity
High
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-427.

Summary

An Uncontrolled Search Path Vulnerability is applicable to the following: Dell Update Package (DUP) Framework file versions prior to 19.1.0.413, and Framework file versions prior to 103.4.6.69 used in Dell EMC Servers. Dell Update Package (DUP) Framework file versions prior to 3.8.3.67 used in Dell Client Platforms. The vulnerability is limited to the DUP framework during the time window when a DUP is being executed by an administrator. During this time window, a locally authenticated low privilege malicious user potentially could exploit this vulnerability by tricking an administrator into running a trusted binary, causing it to load a malicious DLL and allowing the attacker to execute arbitrary code on the victim system. The vulnerability does not affect the actual binary payload that the DUP delivers.

Why it matters now

EPSS 0.00463 40th percentileScored 2026-11-07
Fix Fixed Dell EMC Servers: Networking and Fibre Channel Drivers: Dell Update Package (DUP) Framework file (Dell EMC): 103.4.6.69Dell EMC Servers: all other Drivers, BIOS and Firmware: Dell Update Package (DUP) Framework file (Dell EMC): 19.1.0.413+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Dell EMCDell EMC Servers: Networking and Fibre Channel Drivers: Dell Update Package (DUP) Framework filebefore 103.4.6.69103.4.6.69Patch availableCNA
Dell EMCDell EMC Servers: all other Drivers, BIOS and Firmware: Dell Update Package (DUP) Framework filebefore 19.1.0.41319.1.0.413Patch availableCNA
DellDell Client Platforms: Dell Update Packages (DUP) Framework filebefore 3.8.3.673.8.3.67Patch availableCNA
  • Dell EMC Servers: Networking and Fibre Channel Drivers: Dell Update Package (DUP) Framework file VendorDell EMC Affected before 103.4.6.69 Fixed in 103.4.6.69 Patch available CNA
  • Dell EMC Servers: all other Drivers, BIOS and Firmware: Dell Update Package (DUP) Framework file VendorDell EMC Affected before 19.1.0.413 Fixed in 19.1.0.413 Patch available CNA
  • Dell Client Platforms: Dell Update Packages (DUP) Framework file VendorDell Affected before 3.8.3.67 Fixed in 3.8.3.67 Patch available CNA

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:dell:update_package_framework:*:*:*:*:*:*:*:*before 3.8.3.67VulnerableDell
cpe:2.3:h:dell:client_platforms:-:*:*:*:*:*:*:*not specified by NVDRunning onDell
cpe:2.3:a:dell:update_package_framework:*:*:*:*:*:*:*:*before 103.4.6.69VulnerableDell
cpe:2.3:h:dell:emc_servers:-:*:*:*:*:*:*:*not specified by NVDRunning onDell
cpe:2.3:a:dell:update_package_framework:*:*:*:*:*:*:*:*before 19.1.0.413VulnerableDell
  • cpe:2.3:a:dell:update_package_framework:*:*:*:*:*:*:*:* Versions before 3.8.3.67 Vulnerable ·Dell
  • cpe:2.3:h:dell:client_platforms:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
  • cpe:2.3:a:dell:update_package_framework:*:*:*:*:*:*:*:* Versions before 103.4.6.69 Vulnerable ·Dell
  • cpe:2.3:h:dell:emc_servers:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
  • cpe:2.3:a:dell:update_package_framework:*:*:*:*:*:*:*:* Versions before 19.1.0.413 Vulnerable ·Dell

Remediation

  • Fix · CNA Dell EMC Servers: Networking and Fibre Channel Drivers: Dell Update Package (DUP) Framework file (Dell EMC) Fixed in 103.4.6.69
  • Fix · CNA Dell EMC Servers: all other Drivers, BIOS and Firmware: Dell Update Package (DUP) Framework file (Dell EMC) Fixed in 19.1.0.413
  • Fix · CNA Dell Client Platforms: Dell Update Packages (DUP) Framework file (Dell) Fixed in 3.8.3.67

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-3726
  2. 2026-10-03 Alias added: GHSA-c3v3-2rrj-72gc

References

  • TI-2018-01128 Missing authorization in Dell EMC Avamar, Integrated Data Protection Appliance CVSS 3.0CRITICAL 9.8
  • TI-2018-01141 OS command injection in Dell EMC RecoverPoint CVSS 3.0CRITICAL 9.8
  • TI-2018-07852 Dell EMC Avamar and Integrated Data Protection Appliance Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
  • TI-2017-05620 EMC Networker Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
  • TI-2018-11243 Dell EMC ESRS Policy Manager versions 6.8 and prior contain a remote code execution… CVSS 3.0CRITICAL 9.8
  • TI-2017-08041 OS command injection in Dell EMC Data Protection Advisor CVSS 3.1HIGH 8.8
See all 96 →

Sources