Protection mechanism failure in Dell EMC Unity
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA. Impact type from CWE-693.
Summary
Dell EMC Unity and UnityVSA versions prior to 5.0.0.0.5.116 contain a plain-text password storage vulnerability. A Unisphere user’s (including the admin privilege user) password is stored in a plain text in Unity Data Collection bundle (logs files for troubleshooting). A local authenticated attacker with access to the Data Collection bundle may use the exposed password to gain access with the privileges of the compromised user.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell EMC | Unity | 5.0 to before 5.0.0.0.5.116 | 5.0.0.0.5.116 | Patch available | CNA |
- Unity VendorDell EMC Affected 5.0 to before 5.0.0.0.5.116 Fixed in 5.0.0.0.5.116 Patch available CNA
Remediation
- Fix · CNA Unity (DELL EMC) Fixed in 5.0.0.0.5.116
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
DELL EMC Unity 5.0.0.0.5.116
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-02753 Dell EMC Unity and UnityVSA versions prior to 5.0.0.0.5.116 contain an improper…Priority LOW 27
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3741
- 2026-10-03 Alias added: GHSA-gccr-28w8-pgcj
References
More Dell EMC vulnerabilities
- TI-2018-01128 Missing authorization in Dell EMC Avamar, Integrated Data Protection Appliance CVSS 3.0CRITICAL 9.8
- TI-2018-01141 OS command injection in Dell EMC RecoverPoint CVSS 3.0CRITICAL 9.8
- TI-2018-07852 Dell EMC Avamar and Integrated Data Protection Appliance Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2017-05620 EMC Networker Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2018-11243 Dell EMC ESRS Policy Manager versions 6.8 and prior contain a remote code execution… CVSS 3.0CRITICAL 9.8
- TI-2017-08041 OS command injection in Dell EMC Data Protection Advisor CVSS 3.1HIGH 8.8
Sources
- CVE-2019-3741 · CVE Program
- CVE-2019-3741 · NVD
- FIRST EPSS
- GHSA-gccr-28w8-pgcj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences