Insecure Randomness When Using a SecureRandom Instance Constructed by Spring Security
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Spring Security versions 4.2.x prior to 4.2.12, 5.0.x prior to 5.0.12, and 5.1.x prior to 5.1.5 contain an insecure randomness vulnerability when using SecureRandomFactoryBean#setSeed to configure a SecureRandom instance. In order to be impacted, an honest application must provide a seed and make the resulting random material available to an attacker for inspection.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| VMware | Spring Security | 5.0 to before 5.0.11.RELEASE; 5.1 to before 5.1.4.RELEASE; 4.2 to before 4.2.11.RELEASE | 5.0.11.RELEASE, 5.1.4.RELEASE, 4.2.11.RELEASE | Patch available | CNA |
| — | org.springframework.security:spring-security-core (Maven) | 4.2.0 to before 4.2.12 | 4.2.12 | Patch available | GHSA-v2r2-7qm7-jj6v |
| — | org.springframework.security:spring-security-core (Maven) | 5.0.0 to before 5.0.12 | 5.0.12 | Patch available | GHSA-v2r2-7qm7-jj6v |
| — | org.springframework.security:spring-security-core (Maven) | 5.1.0 to before 5.1.5 | 5.1.5 | Patch available | GHSA-v2r2-7qm7-jj6v |
- Spring Security VendorVMware Affected 5.0 to before 5.0.11.RELEASE; 5.1 to before 5.1.4.RELEASE; 4.2 to before 4.2.11.RELEASE Fixed in 5.0.11.RELEASE, 5.1.4.RELEASE, 4.2.11.RELEASE Patch available CNA
- org.springframework.security:spring-security-core (Maven) Vendor— Affected 4.2.0 to before 4.2.12 Fixed in 4.2.12 Patch available GHSA-v2r2-7qm7-jj6v
- org.springframework.security:spring-security-core (Maven) Vendor— Affected 5.0.0 to before 5.0.12 Fixed in 5.0.12 Patch available GHSA-v2r2-7qm7-jj6v
- org.springframework.security:spring-security-core (Maven) Vendor— Affected 5.1.0 to before 5.1.5 Fixed in 5.1.5 Patch available GHSA-v2r2-7qm7-jj6v
Remediation
- Fix · CNA Spring Security (Spring) Fixed in 5.0.11.RELEASE, 5.1.4.RELEASE, 4.2.11.RELEASE
- Fix · GHSA-v2r2-7qm7-jj6v org.springframework.security:spring-security-core (Maven) Fixed in 4.2.12 Advisory →
- Fix · GHSA-v2r2-7qm7-jj6v org.springframework.security:spring-security-core (Maven) Fixed in 5.0.12 Advisory →
- Fix · GHSA-v2r2-7qm7-jj6v org.springframework.security:spring-security-core (Maven) Fixed in 5.1.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Fuse 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Fuse 6 | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 9 (Mitaka) | Affected | No fix planned: Will not fix |
Not affected: 3 products
- Red Hat OpenStack Platform 13 (Queens)
- Red Hat OpenStack Platform 14 (Rocky)
- Red Hat OpenStack Platform 8 (Liberty)
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3795
- 2026-10-03 Alias added: GHSA-v2r2-7qm7-jj6v
References
More VMware Spring Security vulnerabilities
- TI-2023-16900 Improper access control in Spring Security CVSS 3.1CRITICAL 9.8
- TI-2022-13611 Authorization bypass in Spring by VMware CVSS 3.1CRITICAL 9.8
- TI-2022-07154 Incorrect authorization in Spring Security CVSS 3.1CRITICAL 9.8
- TI-2026-42404 Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces CVSS 3.1CRITICAL 9.4
- TI-2026-18257 Under Some Conditions Spring Security HTTP Headers Are not Written CVSS 3.1CRITICAL 9.1
- TI-2014-02853 Improper authentication in Pivotal Spring Security CVSS 3.0CRITICAL 9.8
Sources
- CVE-2019-3795 · CVE Program
- CVE-2019-3795 · NVD
- FIRST EPSS
- GHSA-v2r2-7qm7-jj6v · GitHub Advisory Database · CC BY 4.0
- CVE-2019-3795 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences