Improper access control in Spring Security
Priority MEDIUM 56CWE-281Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-284.
Summary
Using "**" as a pattern in Spring Security configuration for WebFlux creates a mismatch in pattern matching between Spring Security and Spring WebFlux, and the potential for a security bypass.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.04074 90th percentileScored 2026-11-07
Fix Partial org.springframework.security:spring-security-config (Maven): 5.6.12, 5.7.10, 5.8.5 +2Red Hat: 1 advisoryRed Hat: 1 fixed, 2 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Spring Security | Spring Security 6.1.0 – 6.1.1; Spring Security 6.0.0 – 6.0.4; Spring Security 5.8.0 – 5.8.4; Spring Security 5.7.0 – 5.7.9 ; Spring Security 5.6.0 – 5.6.11 | — | No fix listed | CNA |
| — | org.springframework.security:spring-security-config (Maven) | 5.6.0 to before 5.6.12 | 5.6.12 | Patch available | GHSA-3h6f-g5f3-gc4w |
| — | org.springframework.security:spring-security-config (Maven) | 5.7.0 to before 5.7.10 | 5.7.10 | Patch available | GHSA-3h6f-g5f3-gc4w |
| — | org.springframework.security:spring-security-config (Maven) | 5.8.0 to before 5.8.5 | 5.8.5 | Patch available | GHSA-3h6f-g5f3-gc4w |
| — | org.springframework.security:spring-security-config (Maven) | 6.0.0 to before 6.0.5 | 6.0.5 | Patch available | GHSA-3h6f-g5f3-gc4w |
| — | org.springframework.security:spring-security-config (Maven) | 6.1.0 to before 6.1.2 | 6.1.2 | Patch available | GHSA-3h6f-g5f3-gc4w |
- Spring Security Vendor— Affected Spring Security 6.1.0 – 6.1.1; Spring Security 6.0.0 – 6.0.4; Spring Security 5.8.0 – 5.8.4; Spring Security 5.7.0 – 5.7.9 ; Spring Security 5.6.0 – 5.6.11 Fixed in — No fix listed CNA
- org.springframework.security:spring-security-config (Maven) Vendor— Affected 5.6.0 to before 5.6.12 Fixed in 5.6.12 Patch available GHSA-3h6f-g5f3-gc4w
- org.springframework.security:spring-security-config (Maven) Vendor— Affected 5.7.0 to before 5.7.10 Fixed in 5.7.10 Patch available GHSA-3h6f-g5f3-gc4w
- org.springframework.security:spring-security-config (Maven) Vendor— Affected 5.8.0 to before 5.8.5 Fixed in 5.8.5 Patch available GHSA-3h6f-g5f3-gc4w
- org.springframework.security:spring-security-config (Maven) Vendor— Affected 6.0.0 to before 6.0.5 Fixed in 6.0.5 Patch available GHSA-3h6f-g5f3-gc4w
- org.springframework.security:spring-security-config (Maven) Vendor— Affected 6.1.0 to before 6.1.2 Fixed in 6.1.2 Patch available GHSA-3h6f-g5f3-gc4w
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vmware:spring_security:*:*:*:*:*:*:*:* | 5.6.0 to before 5.6.12; 5.7.0 to before 5.7.10; 5.8.0 to before 5.8.5; 6.0.0 to before 6.0.5; 6.1.0 to before 6.1.2 | Vulnerable | VMware |
- cpe:2.3:a:vmware:spring_security:*:*:*:*:*:*:*:* Versions 5.6.0 to before 5.6.12; 5.7.0 to before 5.7.10; 5.8.0 to before 5.8.5; 6.0.0 to before 6.0.5; 6.1.0 to before 6.1.2 Vulnerable ·VMware
Remediation
- Fix · GHSA-3h6f-g5f3-gc4w org.springframework.security:spring-security-config (Maven) Fixed in 5.6.12 Advisory →
- Fix · GHSA-3h6f-g5f3-gc4w org.springframework.security:spring-security-config (Maven) Fixed in 5.7.10 Advisory →
- Fix · GHSA-3h6f-g5f3-gc4w org.springframework.security:spring-security-config (Maven) Fixed in 5.8.5 Advisory →
- Fix · GHSA-3h6f-g5f3-gc4w org.springframework.security:spring-security-config (Maven) Fixed in 6.0.5 Advisory →
- Fix · GHSA-3h6f-g5f3-gc4w org.springframework.security:spring-security-config (Maven) Fixed in 6.1.2 Advisory →
Red Hat 1 advisory
- RHSA-2023:7247 Released 2023-11-15 · Red Hat rating CriticalRed Hat Fuse 7.12.1 release and security update
- Red Hat Fuse 7.12.1
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat JBoss Fuse 6 | Affected | No fix planned: Out of support scope |
| Red Hat Process Automation 7 | Affected | No fix yet |
| Red Hat Fuse 7.12.1 | Fixed | RHSA-2023:7247 |
Not affected: 3 products
- Red Hat Integration Camel Quarkus 2
- Red Hat Single Sign-On 7
- Red Hat build of Quarkus
Timeline
- 2026-10-02 Threatist record created from CVE-2023-34034
- 2026-10-03 Alias added: GHSA-3h6f-g5f3-gc4w
References
More VMware Spring Security vulnerabilities
- TI-2022-13611 Authorization bypass in Spring by VMware CVSS 3.1CRITICAL 9.8
- TI-2022-07154 Incorrect authorization in Spring Security CVSS 3.1CRITICAL 9.8
- TI-2026-42404 Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces CVSS 3.1CRITICAL 9.4
- TI-2026-18257 Under Some Conditions Spring Security HTTP Headers Are not Written CVSS 3.1CRITICAL 9.1
- TI-2014-02853 Improper authentication in Pivotal Spring Security CVSS 3.0CRITICAL 9.8
- TI-2021-05104 Improper privilege management in Spring Security CVSS 3.1HIGH 8.8
Sources
- CVE-2023-34034 · CVE Program
- CVE-2023-34034 · NVD
- FIRST EPSS
- GHSA-3h6f-g5f3-gc4w · GitHub Advisory Database · CC BY 4.0
- CVE-2023-34034 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences