Read the docs
TI-2019-02820 Aliases CVE-2019-3808GHSA-4r2p-wpv5-683w

Cross-site scripting in [UNKNOWN] moodle

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A flaw was found in Moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions. The 'manage groups' capability did not have the 'XSS risk' flag assigned to it, but does have that access in certain places. Note that the capability is intended for use by trusted users, and is only assigned to teachers and managers by default.

Why it matters now

EPSS 0.01228 69th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.6.2, 3.5.4, 3.4.7 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
[UNKNOWN]moodle3.6.2; 3.5.4; 3.4.7; 3.1.16—No fix listedCNA
—moodle/moodle (Packagist)3.6.0 to before 3.6.23.6.2Patch availableGHSA-4r2p-wpv5-683w
—moodle/moodle (Packagist)3.5.0 to before 3.5.43.5.4Patch availableGHSA-4r2p-wpv5-683w
—moodle/moodle (Packagist)3.2.0 to before 3.4.73.4.7Patch availableGHSA-4r2p-wpv5-683w
—moodle/moodle (Packagist)before 3.1.163.1.16Patch availableGHSA-4r2p-wpv5-683w
  • moodle Vendor[UNKNOWN] Affected 3.6.2; 3.5.4; 3.4.7; 3.1.16 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.6.0 to before 3.6.2 Fixed in 3.6.2 Patch available GHSA-4r2p-wpv5-683w
  • moodle/moodle (Packagist) Vendor— Affected 3.5.0 to before 3.5.4 Fixed in 3.5.4 Patch available GHSA-4r2p-wpv5-683w
  • moodle/moodle (Packagist) Vendor— Affected 3.2.0 to before 3.4.7 Fixed in 3.4.7 Patch available GHSA-4r2p-wpv5-683w
  • moodle/moodle (Packagist) Vendor— Affected before 3.1.16 Fixed in 3.1.16 Patch available GHSA-4r2p-wpv5-683w

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.1.0 – 3.1.15; 3.4.0 – 3.4.6; 3.5.0 – 3.5.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.6.0:*:*:*:*:*:*:*3.6.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.6.1:*:*:*:*:*:*:*3.6.1VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.1.0 – 3.1.15; 3.4.0 – 3.4.6; 3.5.0 – 3.5.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.6.0:*:*:*:*:*:*:* Versions 3.6.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.6.1:*:*:*:*:*:*:* Versions 3.6.1 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-4r2p-wpv5-683w moodle/moodle (Packagist) Fixed in 3.6.2 Advisory →
  • Fix · GHSA-4r2p-wpv5-683w moodle/moodle (Packagist) Fixed in 3.5.4 Advisory →
  • Fix · GHSA-4r2p-wpv5-683w moodle/moodle (Packagist) Fixed in 3.4.7 Advisory →
  • Fix · GHSA-4r2p-wpv5-683w moodle/moodle (Packagist) Fixed in 3.1.16 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-3808
  2. 2026-10-03 Alias added: GHSA-4r2p-wpv5-683w

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources