Cross-site scripting in [UNKNOWN] moodle
Priority MEDIUM 42CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A flaw was found in moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions. The /userpix/ page did not escape users' full names, which are included as text when hovering over profile images. Note this page is not linked to by default and its access is restricted.
Why it matters now
EPSS 0.13841 96th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed moodle/moodle (Packagist): 3.6.1, 3.5.3, 3.4.6 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| [UNKNOWN] | moodle | 3.6.2; 3.5.4; 3.4.7; 3.1.16 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.6.0 to before 3.6.1 | 3.6.1 | Patch available | GHSA-wm4w-8vc6-2j4h |
| — | moodle/moodle (Packagist) | 3.5.0 to before 3.5.3 | 3.5.3 | Patch available | GHSA-wm4w-8vc6-2j4h |
| — | moodle/moodle (Packagist) | 3.4.0 to before 3.4.6 | 3.4.6 | Patch available | GHSA-wm4w-8vc6-2j4h |
| — | moodle/moodle (Packagist) | 3.1.0 to before 3.1.15 | 3.1.15 | Patch available | GHSA-wm4w-8vc6-2j4h |
- moodle Vendor[UNKNOWN] Affected 3.6.2; 3.5.4; 3.4.7; 3.1.16 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.6.0 to before 3.6.1 Fixed in 3.6.1 Patch available GHSA-wm4w-8vc6-2j4h
- moodle/moodle (Packagist) Vendor— Affected 3.5.0 to before 3.5.3 Fixed in 3.5.3 Patch available GHSA-wm4w-8vc6-2j4h
- moodle/moodle (Packagist) Vendor— Affected 3.4.0 to before 3.4.6 Fixed in 3.4.6 Patch available GHSA-wm4w-8vc6-2j4h
- moodle/moodle (Packagist) Vendor— Affected 3.1.0 to before 3.1.15 Fixed in 3.1.15 Patch available GHSA-wm4w-8vc6-2j4h
Remediation
- Fix · GHSA-wm4w-8vc6-2j4h moodle/moodle (Packagist) Fixed in 3.6.1 Advisory →
- Fix · GHSA-wm4w-8vc6-2j4h moodle/moodle (Packagist) Fixed in 3.5.3 Advisory →
- Fix · GHSA-wm4w-8vc6-2j4h moodle/moodle (Packagist) Fixed in 3.4.6 Advisory →
- Fix · GHSA-wm4w-8vc6-2j4h moodle/moodle (Packagist) Fixed in 3.1.15 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3810
- 2026-10-03 Alias added: GHSA-wm4w-8vc6-2j4h
References
Patch 3
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2019-3810 · CVE Program
- CVE-2019-3810 · NVD
- FIRST EPSS
- GHSA-wm4w-8vc6-2j4h · GitHub Advisory Database · CC BY 4.0
- CVE-2019-3810 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences