Memory corruption in qemu
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-125 and the CVSS impact.
Summary
QEMU, through version 2.10 and through version 3.1.0, is vulnerable to an out-of-bounds read of up to 128 bytes in the hw/i2c/i2c-ddc.c:i2c_ddc() function. A local attacker with permission to execute i2c commands could exploit this to read stack memory of the qemu process on the host.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| QEMU | qemu | through version 2.10 and through to 3.1.0 | — | No fix listed | CNA |
- qemu VendorQEMU Affected through version 2.10 and through to 3.1.0 Fixed in — No fix listed CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* | 2.10.0 – 3.1.0 | Vulnerable | QEMU |
| cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:* | 29 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* | 30 | Vulnerable | Fedoraproject |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.10:*:*:*:*:*:*:* | 18.10 | Vulnerable | Canonical |
| cpe:2.3:o:opensuse:leap:42.3:*:*:*:*:*:*:* | 42.3 | Vulnerable | openSUSE |
- cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* Versions 2.10.0 – 3.1.0 Vulnerable ·QEMU
- cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:* Versions 29 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.10:*:*:*:*:*:*:* Versions 18.10 Vulnerable ·Canonical
- cpe:2.3:o:opensuse:leap:42.3:*:*:*:*:*:*:* Versions 42.3 Vulnerable ·openSUSE
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 9 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat OpenStack Platform 10 (Newton)
- Red Hat OpenStack Platform 13 (Queens)
- Red Hat OpenStack Platform 14 (Rocky)
- Red Hat OpenStack Platform 8 (Liberty)
- Red Hat OpenStack Platform 9 (Mitaka)
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3812
- 2026-10-03 Alias added: GHSA-4mh7-g8hh-qp2p
References
More Qemu vulnerabilities
- TI-2024-16148 QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI… CVSS 3.1HIGH 8.8
- TI-2022-02736 Uncontrolled resource consumption in QEMU CVSS 3.1HIGH 7.8
- TI-2023-02681 Qemu: 9pfs: improper access control on special files CVSS 3.1HIGH 7.1
- TI-2019-09678 The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command… CVSS 3.0CRITICAL 9.8
- TI-2024-03326 Qemu-kvm: net: assertion failure in update_sctp_checksum() CVSS 3.1MEDIUM 5.5
- TI-2023-22631 QEMU through 8.0.0 could trigger a division by zero in scsi_disk_reset in… CVSS 3.1MEDIUM 5.5
Sources
- CVE-2019-3812 · CVE Program
- CVE-2019-3812 · NVD
- FIRST EPSS
- GHSA-4mh7-g8hh-qp2p · GitHub Advisory Database · CC BY 4.0
- CVE-2019-3812 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences