Read the docs
TI-2019-02860 Aliases CVE-2019-3848GHSA-45rw-4r25-jvg7

Incorrect authorization in [UNKNOWN] moodle

Priority LOW 22CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Permissions were not correctly checked before loading event information into the calendar's edit event modal popup, so logged in non-guest users could view unauthorised calendar events. (Note: It was read-only access, users could not edit the events.)

Why it matters now

EPSS 0.00919 60th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.4.8, 3.5.5, 3.6.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
[UNKNOWN]moodle3.6.3; 3.5.5; 3.4.8—No fix listedCNA
—moodle/moodle (Packagist)3.4 to before 3.4.83.4.8Patch availableGHSA-45rw-4r25-jvg7
—moodle/moodle (Packagist)3.5 to before 3.5.53.5.5Patch availableGHSA-45rw-4r25-jvg7
—moodle/moodle (Packagist)3.6 to before 3.6.33.6.3Patch availableGHSA-45rw-4r25-jvg7
  • moodle Vendor[UNKNOWN] Affected 3.6.3; 3.5.5; 3.4.8 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.4 to before 3.4.8 Fixed in 3.4.8 Patch available GHSA-45rw-4r25-jvg7
  • moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.5 Fixed in 3.5.5 Patch available GHSA-45rw-4r25-jvg7
  • moodle/moodle (Packagist) Vendor— Affected 3.6 to before 3.6.3 Fixed in 3.6.3 Patch available GHSA-45rw-4r25-jvg7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 3.4.8; 3.5.0 to before 3.5.5; 3.6.0 to before 3.6.3VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 3.4.8; 3.5.0 to before 3.5.5; 3.6.0 to before 3.6.3 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-45rw-4r25-jvg7 moodle/moodle (Packagist) Fixed in 3.4.8 Advisory →
  • Fix · GHSA-45rw-4r25-jvg7 moodle/moodle (Packagist) Fixed in 3.5.5 Advisory →
  • Fix · GHSA-45rw-4r25-jvg7 moodle/moodle (Packagist) Fixed in 3.6.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-3848
  2. 2026-10-03 Alias added: GHSA-45rw-4r25-jvg7

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources