Uncontrolled resource consumption in NodeJS Node.js
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 7 fixed, 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-400.
Summary
In Node.js including 6.x before 6.17.0, 8.x before 8.15.1, 10.x before 10.15.2, and 11.x before 11.10.1, an attacker can cause a Denial of Service (DoS) by establishing an HTTP or HTTPS connection in keep-alive mode and by sending headers very slowly. This keeps the connection and associated resources alive for a long period of time. Potential attacks are mitigated by the use of a load balancer or other proxy layer. This vulnerability is an extension of CVE-2018-12121, addressed in November and impacts all active Node.js release lines including 6.x before 6.17.0, 8.x before 8.15.1, 10.x before 10.15.2, and 11.x before 11.10.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | Node.js | before 6.17.0; before 8.15.1; before 10.15.2; before 11.10.1 | 6.17.0, 8.15.1, 10.15.2, 11.10.1 | Patch available | CNA |
- Node.js VendorNodeJS Affected before 6.17.0; before 8.15.1; before 10.15.2; before 11.10.1 Fixed in 6.17.0, 8.15.1, 10.15.2, 11.10.1 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* | 6.0.0 to before 6.17.0; 8.0.0 to before 8.15.1; 10.0.0 to before 10.15.2 | Vulnerable | NodeJS |
| cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* | 11.0.0 to before 11.10.1 | Vulnerable | NodeJS |
| cpe:2.3:o:opensuse:leap:42.3:*:*:*:*:*:*:* | 42.3 | Vulnerable | openSUSE |
- cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* Versions 6.0.0 to before 6.17.0; 8.0.0 to before 8.15.1; 10.0.0 to before 10.15.2 Vulnerable ·NodeJS
- cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* Versions 11.0.0 to before 11.10.1 Vulnerable ·NodeJS
- cpe:2.3:o:opensuse:leap:42.3:*:*:*:*:*:*:* Versions 42.3 Vulnerable ·openSUSE
Remediation
- Fix · CNA Node.js (Node.js) Fixed in 6.17.0, 8.15.1, 10.15.2, 11.10.1
Red Hat 3 advisories
- RHSA-2019:2939 Released 2019-10-01 · Red Hat rating Importantrh-nodejs10-nodejs security update
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-nodejs10-3.2-3.el7, rh-nodejs10-nodejs-10.16.3-3.el7, rh-nodejs10-nodejs-devel-10.16.3-3.el7 +4
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.5) rh-nodejs10-3.2-3.el7, rh-nodejs10-nodejs-10.16.3-3.el7, rh-nodejs10-nodejs-devel-10.16.3-3.el7 +4
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6) rh-nodejs10-3.2-3.el7, rh-nodejs10-nodejs-10.16.3-3.el7, rh-nodejs10-nodejs-devel-10.16.3-3.el7 +4
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) rh-nodejs10-3.2-3.el7, rh-nodejs10-nodejs-10.16.3-3.el7, rh-nodejs10-nodejs-devel-10.16.3-3.el7 +4
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-nodejs10-3.2-3.el7, rh-nodejs10-nodejs-10.16.3-3.el7, rh-nodejs10-nodejs-devel-10.16.3-3.el7 +4
- RHSA-2019:2925 Released 2019-09-30 · Red Hat rating Importantnodejs:10 security update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:10.16.3-2.module+el8.0.0+4214+49953fda.aarch64::nodejs:10, nodejs-1:10.16.3-2.module+el8.0.0+4214+49953fda.ppc64le::nodejs:10, nodejs-1:10.16.3-2.module+el8.0.0+4214+49953fda.s390x::nodejs:10 +15
- RHSA-2019:1821 Released 2019-07-22 · Red Hat rating Importantrh-nodejs8-nodejs security update
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-nodejs8-nodejs-8.16.0-1.el7, rh-nodejs8-nodejs-devel-8.16.0-1.el7, rh-nodejs8-nodejs-docs-8.16.0-1.el7 +1
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.4) rh-nodejs8-nodejs-8.16.0-1.el7, rh-nodejs8-nodejs-devel-8.16.0-1.el7, rh-nodejs8-nodejs-docs-8.16.0-1.el7 +1
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.5) rh-nodejs8-nodejs-8.16.0-1.el7, rh-nodejs8-nodejs-devel-8.16.0-1.el7, rh-nodejs8-nodejs-docs-8.16.0-1.el7 +1
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6) rh-nodejs8-nodejs-8.16.0-1.el7, rh-nodejs8-nodejs-devel-8.16.0-1.el7, rh-nodejs8-nodejs-docs-8.16.0-1.el7 +1
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-nodejs8-nodejs-8.16.0-1.el7, rh-nodejs8-nodejs-devel-8.16.0-1.el7, rh-nodejs8-nodejs-docs-8.16.0-1.el7 +1
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 3.6 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 3.7 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2019:2925 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2019:1821, RHSA-2019:2939 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.4) | Fixed | RHSA-2019:1821 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.5) | Fixed | RHSA-2019:1821, RHSA-2019:2939 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6) | Fixed | RHSA-2019:1821, RHSA-2019:2939 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) | Fixed | RHSA-2019:2939 |
| Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2019:1821, RHSA-2019:2939 |
Not affected: 1 product
- Red Hat OpenShift Application Runtimes
Timeline
- 2026-10-02 Threatist record created from CVE-2019-5737
- 2026-10-03 Alias added: GHSA-24mv-c2pp-2q4f
References
More NodeJS Node.js vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
- TI-2022-03315 X.509 Email Address 4-byte Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2019-5737 · CVE Program
- CVE-2019-5737 · NVD
- FIRST EPSS
- GHSA-24mv-c2pp-2q4f · GitHub Advisory Database · CC BY 4.0
- CVE-2019-5737 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences