Moodle 3.5.x before 3.5.4 allows SSRF.
Priority LOW 36CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Moodle 3.5.x before 3.5.4 allows SSRF.
Why it matters now
EPSS 0.01418 72nd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.5.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.5.0 to before 3.5.4 | 3.5.4 | Patch available | GHSA-vjxx-54vw-q59f |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.5.0 to before 3.5.4 Fixed in 3.5.4 Patch available GHSA-vjxx-54vw-q59f
Remediation
- Fix · GHSA-vjxx-54vw-q59f moodle/moodle (Packagist) Fixed in 3.5.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-6970
- 2026-10-03 Alias added: GHSA-vjxx-54vw-q59f
References
Advisory 2
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2019-6970 · CVE Program
- CVE-2019-6970 · NVD
- FIRST EPSS
- GHSA-vjxx-54vw-q59f · GitHub Advisory Database · CC BY 4.0
- CVE-2019-6970 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences