Cross-site request forgery in Magento 2
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A cross-site request forgery (CSRF) vulnerability exists in the checkout cart item of Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited at the time of editing or configuration.
Why it matters now
EPSS 0.00497 42nd percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.1.18, 2.2.9, 2.3.2magento/product-community-edition (Packagist): 2.1.18, 2.2.9, 2.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Magento 2 | Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2 | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | 2.1.0 to before 2.1.18 | 2.1.18 | Patch available | GHSA-wmrg-w9vg-7jqx |
| — | magento/community-edition (Packagist) | 2.2.0 to before 2.2.9 | 2.2.9 | Patch available | GHSA-wmrg-w9vg-7jqx |
| — | magento/community-edition (Packagist) | 2.3.0 to before 2.3.2 | 2.3.2 | Patch available | GHSA-wmrg-w9vg-7jqx |
| — | magento/product-community-edition (Packagist) | 2.1 to before 2.1.18 | 2.1.18 | Patch available | GHSA-wmrg-w9vg-7jqx |
| — | magento/product-community-edition (Packagist) | 2.2 to before 2.2.9 | 2.2.9 | Patch available | GHSA-wmrg-w9vg-7jqx |
| — | magento/product-community-edition (Packagist) | 2.3 to before 2.3.2 | 2.3.2 | Patch available | GHSA-wmrg-w9vg-7jqx |
- Magento 2 Vendor— Affected Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2 Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected 2.1.0 to before 2.1.18 Fixed in 2.1.18 Patch available GHSA-wmrg-w9vg-7jqx
- magento/community-edition (Packagist) Vendor— Affected 2.2.0 to before 2.2.9 Fixed in 2.2.9 Patch available GHSA-wmrg-w9vg-7jqx
- magento/community-edition (Packagist) Vendor— Affected 2.3.0 to before 2.3.2 Fixed in 2.3.2 Patch available GHSA-wmrg-w9vg-7jqx
- magento/product-community-edition (Packagist) Vendor— Affected 2.1 to before 2.1.18 Fixed in 2.1.18 Patch available GHSA-wmrg-w9vg-7jqx
- magento/product-community-edition (Packagist) Vendor— Affected 2.2 to before 2.2.9 Fixed in 2.2.9 Patch available GHSA-wmrg-w9vg-7jqx
- magento/product-community-edition (Packagist) Vendor— Affected 2.3 to before 2.3.2 Fixed in 2.3.2 Patch available GHSA-wmrg-w9vg-7jqx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | 2.1.0 to before 2.1.18; 2.2.0 to before 2.2.9; 2.3.0 to before 2.3.2 | Vulnerable | Magento |
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.1.0 to before 2.1.18; 2.2.0 to before 2.2.9; 2.3.0 to before 2.3.2 Vulnerable ·Magento
Remediation
- Fix · GHSA-wmrg-w9vg-7jqx magento/community-edition (Packagist) Fixed in 2.1.18 Advisory →
- Fix · GHSA-wmrg-w9vg-7jqx magento/community-edition (Packagist) Fixed in 2.2.9 Advisory →
- Fix · GHSA-wmrg-w9vg-7jqx magento/community-edition (Packagist) Fixed in 2.3.2 Advisory →
- Fix · GHSA-wmrg-w9vg-7jqx magento/product-community-edition (Packagist) Fixed in 2.1.18 Advisory →
- Fix · GHSA-wmrg-w9vg-7jqx magento/product-community-edition (Packagist) Fixed in 2.2.9 Advisory →
- Fix · GHSA-wmrg-w9vg-7jqx magento/product-community-edition (Packagist) Fixed in 2.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-7865
- 2026-10-03 Alias added: GHSA-wmrg-w9vg-7jqx
References
Advisory 2
More Magento vulnerabilities
- TI-2016-03411 Magento CE and EE before 2.0.6 allows remote attackers to conduct PHP objection injection… CVSS 3.0CRITICAL 9.8
- TI-2021-04135 Magento Commerce Reflected Cross-site Scripting Vulnerability Could Lead To Arbitrary JavaScript Execution CVSS 3.1MEDIUM 4.8
- TI-2019-05058 SQL injection in Magento Open Source CVSS 3.0CRITICAL 9.8
- TI-2015-01273 SQL injection vulnerability in the getCsvFile function in the… CVSS 2.0MEDIUM 6.5
- TI-2022-15170 Adobe Commerce Stored XSS Arbitrary code execution CVSS 3.1MEDIUM 4.8
- TI-2020-03231 Deserialization of untrusted data in Adobe Magento CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-7865 · CVE Program
- CVE-2019-7865 · NVD
- FIRST EPSS
- GHSA-wmrg-w9vg-7jqx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences