Read the docs
TI-2019-05601 Aliases CVE-2019-7908GHSA-mgfv-4whf-c574

Cross-site scripting in Magento 2

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A stored cross-site scripting vulnerability exists in the admin panel of Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to modify product information.

Why it matters now

EPSS 0.00557 46th percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.1.18, 2.2.9, 2.3.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Magento 2Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2—No fix listedCNA
—magento/community-edition (Packagist)2.1.0 to before 2.1.182.1.18Patch availableGHSA-mgfv-4whf-c574
—magento/community-edition (Packagist)2.2.0 to before 2.2.92.2.9Patch availableGHSA-mgfv-4whf-c574
—magento/community-edition (Packagist)2.3.0 to before 2.3.22.3.2Patch availableGHSA-mgfv-4whf-c574
  • Magento 2 Vendor— Affected Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2 Fixed in — No fix listed CNA
  • magento/community-edition (Packagist) Vendor— Affected 2.1.0 to before 2.1.18 Fixed in 2.1.18 Patch available GHSA-mgfv-4whf-c574
  • magento/community-edition (Packagist) Vendor— Affected 2.2.0 to before 2.2.9 Fixed in 2.2.9 Patch available GHSA-mgfv-4whf-c574
  • magento/community-edition (Packagist) Vendor— Affected 2.3.0 to before 2.3.2 Fixed in 2.3.2 Patch available GHSA-mgfv-4whf-c574

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*2.1.0 to before 2.1.18; 2.2.0 to before 2.2.9; 2.3.0 to before 2.3.2VulnerableMagento
  • cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.1.0 to before 2.1.18; 2.2.0 to before 2.2.9; 2.3.0 to before 2.3.2 Vulnerable ·Magento

Remediation

  • Fix · GHSA-mgfv-4whf-c574 magento/community-edition (Packagist) Fixed in 2.1.18 Advisory →
  • Fix · GHSA-mgfv-4whf-c574 magento/community-edition (Packagist) Fixed in 2.2.9 Advisory →
  • Fix · GHSA-mgfv-4whf-c574 magento/community-edition (Packagist) Fixed in 2.3.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-7908
  2. 2026-10-03 Alias added: GHSA-mgfv-4whf-c574

References

  • TI-2016-03411 Magento CE and EE before 2.0.6 allows remote attackers to conduct PHP objection injection… CVSS 3.0CRITICAL 9.8
  • TI-2021-04135 Magento Commerce Reflected Cross-site Scripting Vulnerability Could Lead To Arbitrary JavaScript Execution CVSS 3.1MEDIUM 4.8
  • TI-2019-05058 SQL injection in Magento Open Source CVSS 3.0CRITICAL 9.8
  • TI-2015-01273 SQL injection vulnerability in the getCsvFile function in the… CVSS 2.0MEDIUM 6.5
  • TI-2022-15170 Adobe Commerce Stored XSS Arbitrary code execution CVSS 3.1MEDIUM 4.8
  • TI-2020-03231 Deserialization of untrusted data in Adobe Magento CVSS 3.1CRITICAL 9.8
See all 220 →

Sources