Read the docs
TI-2019-07412 Aliases CVE-2019-10087GHSA-gwfq-qwmp-x9xg

Cross-site scripting in Apache JSPWiki

Priority LOW 33CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

On Apache JSPWiki, up to version 2.11.0.M4, a carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the Page Revision History, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim.

Why it matters now

EPSS 0.02913 87th percentileScored 2026-11-07
Fix Fixed org.apache.jspwiki:jspwiki-war (Maven): 2.11.0.M5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Apache JSPWikiApache JSPWiki up to 2.11.0.M4—No fix listedCNA
—org.apache.jspwiki:jspwiki-war (Maven)2.9.0 to before 2.11.0.M52.11.0.M5Patch availableGHSA-gwfq-qwmp-x9xg
  • Apache JSPWiki Vendor— Affected Apache JSPWiki up to 2.11.0.M4 Fixed in — No fix listed CNA
  • org.apache.jspwiki:jspwiki-war (Maven) Vendor— Affected 2.9.0 to before 2.11.0.M5 Fixed in 2.11.0.M5 Patch available GHSA-gwfq-qwmp-x9xg

CPE configurations NVD · 13

CPEVersionsRoleVendor
cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:*up to 2.10.5VulnerableApache
cpe:2.3:a:apache:jspwiki:2.11.0:m1:*:*:*:*:*:*2.11.0 m1VulnerableApache
cpe:2.3:a:apache:jspwiki:2.11.0:m1-rc1:*:*:*:*:*:*2.11.0 m1-rc1VulnerableApache
cpe:2.3:a:apache:jspwiki:2.11.0:m1-rc2:*:*:*:*:*:*2.11.0 m1-rc2VulnerableApache
cpe:2.3:a:apache:jspwiki:2.11.0:m1-rc3:*:*:*:*:*:*2.11.0 m1-rc3VulnerableApache
cpe:2.3:a:apache:jspwiki:2.11.0:m2:*:*:*:*:*:*2.11.0 m2VulnerableApache
cpe:2.3:a:apache:jspwiki:2.11.0:m2-rc1:*:*:*:*:*:*2.11.0 m2-rc1VulnerableApache
cpe:2.3:a:apache:jspwiki:2.11.0:m3:*:*:*:*:*:*2.11.0 m3VulnerableApache
cpe:2.3:a:apache:jspwiki:2.11.0:m3-rc1:*:*:*:*:*:*2.11.0 m3-rc1VulnerableApache
cpe:2.3:a:apache:jspwiki:2.11.0:m3-rc2:*:*:*:*:*:*2.11.0 m3-rc2VulnerableApache
  • cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:* Versions up to 2.10.5 Vulnerable ·Apache
  • cpe:2.3:a:apache:jspwiki:2.11.0:m1:*:*:*:*:*:* Versions 2.11.0 m1 Vulnerable ·Apache
  • cpe:2.3:a:apache:jspwiki:2.11.0:m1-rc1:*:*:*:*:*:* Versions 2.11.0 m1-rc1 Vulnerable ·Apache
  • cpe:2.3:a:apache:jspwiki:2.11.0:m1-rc2:*:*:*:*:*:* Versions 2.11.0 m1-rc2 Vulnerable ·Apache
  • cpe:2.3:a:apache:jspwiki:2.11.0:m1-rc3:*:*:*:*:*:* Versions 2.11.0 m1-rc3 Vulnerable ·Apache
  • cpe:2.3:a:apache:jspwiki:2.11.0:m2:*:*:*:*:*:* Versions 2.11.0 m2 Vulnerable ·Apache
  • cpe:2.3:a:apache:jspwiki:2.11.0:m2-rc1:*:*:*:*:*:* Versions 2.11.0 m2-rc1 Vulnerable ·Apache
  • cpe:2.3:a:apache:jspwiki:2.11.0:m3:*:*:*:*:*:* Versions 2.11.0 m3 Vulnerable ·Apache
  • cpe:2.3:a:apache:jspwiki:2.11.0:m3-rc1:*:*:*:*:*:* Versions 2.11.0 m3-rc1 Vulnerable ·Apache
  • cpe:2.3:a:apache:jspwiki:2.11.0:m3-rc2:*:*:*:*:*:* Versions 2.11.0 m3-rc2 Vulnerable ·Apache
Show 3 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:apache:jspwiki:2.11.0:m4:*:*:*:*:*:*2.11.0 m4VulnerableApache
cpe:2.3:a:apache:jspwiki:2.11.0:m4-rc1:*:*:*:*:*:*2.11.0 m4-rc1VulnerableApache
cpe:2.3:a:apache:jspwiki:2.11.0:m4-rc2:*:*:*:*:*:*2.11.0 m4-rc2VulnerableApache
  • cpe:2.3:a:apache:jspwiki:2.11.0:m4:*:*:*:*:*:* Versions 2.11.0 m4 Vulnerable ·Apache
  • cpe:2.3:a:apache:jspwiki:2.11.0:m4-rc1:*:*:*:*:*:* Versions 2.11.0 m4-rc1 Vulnerable ·Apache
  • cpe:2.3:a:apache:jspwiki:2.11.0:m4-rc2:*:*:*:*:*:* Versions 2.11.0 m4-rc2 Vulnerable ·Apache

Remediation

  • Fix · GHSA-gwfq-qwmp-x9xg org.apache.jspwiki:jspwiki-war (Maven) Fixed in 2.11.0.M5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10087
  2. 2026-10-03 Alias added: GHSA-gwfq-qwmp-x9xg

References

  • TI-2022-11364 Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp CVSS 3.1MEDIUM 6.1
  • TI-2022-10292 XSS vulnerability on XHRHtml2Markup.jsp in JSPWiki 2.11.2 CVSS 3.1MEDIUM 6.1
  • TI-2022-11366 Apache JSPWiki Cross-site scripting vulnerability on WeblogPlugin CVSS 3.1MEDIUM 6.1
  • TI-2022-11365 Apache JSPWiki CSRF in UserPreferences.jsp CVSS 3.1MEDIUM 6.5
  • TI-2024-17991 Apache JSPWiki: Cross-site scripting vulnerability on upload page CVSS 3.1MEDIUM 6.1
  • TI-2026-23006 Apache JSPWiki: UserManager does not sanity-check user database at startup CVSS 3.1CRITICAL 9.8
See all 28 →

Sources