Improper certificate validation in Apache Geode
Priority LOW 35CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
When TLS is enabled with ssl-endpoint-identification-enabled set to true, Apache Geode fails to perform hostname verification of the entries in the certificate SAN during the SSL handshake. This could compromise intra-cluster communication using a man-in-the-middle attack.
Why it matters now
EPSS 0.01417 72nd percentileScored 2026-11-07
Fix Fixed org.apache.geode:geode-core (Maven): 1.10.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Apache Geode | Apache Tomcat 1.9.0 | — | No fix listed | CNA |
| — | org.apache.geode:geode-core (Maven) | before 1.10.0 | 1.10.0 | Patch available | GHSA-wc4x-4gm2-74j8 |
- Apache Geode Vendor— Affected Apache Tomcat 1.9.0 Fixed in — No fix listed CNA
- org.apache.geode:geode-core (Maven) Vendor— Affected before 1.10.0 Fixed in 1.10.0 Patch available GHSA-wc4x-4gm2-74j8
Remediation
- Fix · GHSA-wc4x-4gm2-74j8 org.apache.geode:geode-core (Maven) Fixed in 1.10.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10091
- 2026-10-03 Alias added: GHSA-wc4x-4gm2-74j8
References
Advisory 2
More Apache Geode vulnerabilities
- TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2019-11833 Docker Desktop Community Edition before 2.1.0.1 allows local users to gain privileges by… KEVCVSS 3.1HIGH 7.8
- TI-2019-11096 Information disclosure in Red Hat jackson-databind CVSS 3.1CRITICAL 9.8
- TI-2014-00046 Improper input validation in docker.io CVSS 3.1CRITICAL 9.8
- TI-2017-11466 Deserialization of untrusted data in Apache Geode CVSS 3.0CRITICAL 9.8
- TI-2022-17225 Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-10091 · CVE Program
- CVE-2019-10091 · NVD
- FIRST EPSS
- GHSA-wc4x-4gm2-74j8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences