Read the docs
TI-2019-07427 Aliases CVE-2019-10103GHSA-8fr9-3mxv-p3vf

JetBrains IntelliJ IDEA projects created using the Kotlin (JS Client/JVM Server) IDE…

Priority LOW 37CWE-311Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-311.

Summary

JetBrains IntelliJ IDEA projects created using the Kotlin (JS Client/JVM Server) IDE Template were resolving Gradle artifacts using an http connection, potentially allowing an MITM attack. This issue, which was fixed in Kotlin plugin version 1.3.30, is similar to CVE-2019-10101.

Why it matters now

EPSS 0.00813 57th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jetbrains:kotlin:*:*:*:*:*:*:*:*before 1.3.30VulnerableJetBrains
  • cpe:2.3:a:jetbrains:kotlin:*:*:*:*:*:*:*:* Versions before 1.3.30 Vulnerable ·JetBrains

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10103
  2. 2026-10-03 Alias added: GHSA-8fr9-3mxv-p3vf

References

  • TI-2026-38890 In JetBrains Kotlin before 2.4.20 code execution was possible via unsafe deserialization in the build cache metadata CVSS 3.1CRITICAL 9.8
  • TI-2020-12453 In JetBrains Kotlin from 1.4-M1 to 1.4-RC (as Kotlin 1.3.7x is not affected by the issue. CVSS 3.1HIGH 8.8
  • TI-2019-07425 JetBrains Kotlin versions before 1.3.30 were resolving artifacts using an http connection… CVSS 3.1HIGH 8.1
  • TI-2019-07426 JetBrains Ktor framework (created using the Kotlin IDE template) versions before 1.1.0… CVSS 3.0HIGH 8.1
  • TI-2020-17771 In JetBrains Kotlin before 1.4.21, a vulnerable Java API was used for temporary file and… CVSS 3.1MEDIUM 5.3
  • TI-2022-08207 In JetBrains Kotlin before 1.6.0, it was not possible to lock dependencies for Multiplatform Gradle Projects. CVSS 3.1MEDIUM 5.3

Sources