In JetBrains Kotlin before 2.4.20 code execution was possible via unsafe deserialization in the build cache metadata
Priority MEDIUM 43CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
In JetBrains Kotlin before 2.4.20 code execution was possible via unsafe deserialization in the build cache metadata
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0035 28th percentileScored 2026-11-07
Fix Fixed Kotlin (JetBrains): 2.4.20org.jetbrains.kotlin:kotlin-gradle-plugin (Maven): 2.4.20-Beta1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| JetBrains | Kotlin | before 2.4.20 | 2.4.20 | Patch available | CNA |
| — | org.jetbrains.kotlin:kotlin-gradle-plugin (Maven) | before 2.4.20-Beta1 | 2.4.20-Beta1 | Patch available | GHSA-r937-wjx7-w2jp |
- Kotlin VendorJetBrains Affected before 2.4.20 Fixed in 2.4.20 Patch available CNA
- org.jetbrains.kotlin:kotlin-gradle-plugin (Maven) Vendor— Affected before 2.4.20-Beta1 Fixed in 2.4.20-Beta1 Patch available GHSA-r937-wjx7-w2jp
Remediation
- Fix · CNA Kotlin (JetBrains) Fixed in 2.4.20
- Fix · GHSA-r937-wjx7-w2jp org.jetbrains.kotlin:kotlin-gradle-plugin (Maven) Fixed in 2.4.20-Beta1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-53914
- 2026-10-03 Alias added: GHSA-r937-wjx7-w2jp
References
Advisory 2
More JetBrains Kotlin vulnerabilities
- TI-2020-12453 In JetBrains Kotlin from 1.4-M1 to 1.4-RC (as Kotlin 1.3.7x is not affected by the issue. CVSS 3.1HIGH 8.8
- TI-2019-07425 JetBrains Kotlin versions before 1.3.30 were resolving artifacts using an http connection… CVSS 3.1HIGH 8.1
- TI-2019-07427 JetBrains IntelliJ IDEA projects created using the Kotlin (JS Client/JVM Server) IDE… CVSS 3.0HIGH 8.1
- TI-2019-07426 JetBrains Ktor framework (created using the Kotlin IDE template) versions before 1.1.0… CVSS 3.0HIGH 8.1
- TI-2020-17771 In JetBrains Kotlin before 1.4.21, a vulnerable Java API was used for temporary file and… CVSS 3.1MEDIUM 5.3
- TI-2022-08207 In JetBrains Kotlin before 1.6.0, it was not possible to lock dependencies for Multiplatform Gradle Projects. CVSS 3.1MEDIUM 5.3
Sources
- CVE-2026-53914 · CVE Program
- CVE-2026-53914 · NVD
- FIRST EPSS
- GHSA-r937-wjx7-w2jp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences