Read the docs
TI-2019-07456 Aliases CVE-2019-10133GHSA-5xp2-rv4h-mm2q

Open redirect in moodle

Priority LOW 29CWE-601Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Spoofing
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-601.

Summary

A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18. The form to upload cohorts contained a redirect field, which was not restricted to internal URLs.

Why it matters now

EPSS 0.00895 59th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.6.4, 3.5.6, 3.4.9 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Moodlemoodle3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18—No fix listedCNA
—moodle/moodle (Packagist)3.6.0 to before 3.6.43.6.4Patch availableGHSA-5xp2-rv4h-mm2q
—moodle/moodle (Packagist)3.5.0 to before 3.5.63.5.6Patch availableGHSA-5xp2-rv4h-mm2q
—moodle/moodle (Packagist)3.4.0 to before 3.4.93.4.9Patch availableGHSA-5xp2-rv4h-mm2q
—moodle/moodle (Packagist)before 3.1.183.1.18Patch availableGHSA-5xp2-rv4h-mm2q
  • moodle VendorMoodle Affected 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.6.0 to before 3.6.4 Fixed in 3.6.4 Patch available GHSA-5xp2-rv4h-mm2q
  • moodle/moodle (Packagist) Vendor— Affected 3.5.0 to before 3.5.6 Fixed in 3.5.6 Patch available GHSA-5xp2-rv4h-mm2q
  • moodle/moodle (Packagist) Vendor— Affected 3.4.0 to before 3.4.9 Fixed in 3.4.9 Patch available GHSA-5xp2-rv4h-mm2q
  • moodle/moodle (Packagist) Vendor— Affected before 3.1.18 Fixed in 3.1.18 Patch available GHSA-5xp2-rv4h-mm2q

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.1.0 – 3.1.17; 3.4.0 – 3.4.8; 3.5.0 – 3.5.5; 3.6.0 – 3.6.3VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.1.0 – 3.1.17; 3.4.0 – 3.4.8; 3.5.0 – 3.5.5; 3.6.0 – 3.6.3 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-5xp2-rv4h-mm2q moodle/moodle (Packagist) Fixed in 3.6.4 Advisory →
  • Fix · GHSA-5xp2-rv4h-mm2q moodle/moodle (Packagist) Fixed in 3.5.6 Advisory →
  • Fix · GHSA-5xp2-rv4h-mm2q moodle/moodle (Packagist) Fixed in 3.4.9 Advisory →
  • Fix · GHSA-5xp2-rv4h-mm2q moodle/moodle (Packagist) Fixed in 3.1.18 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10133
  2. 2026-10-03 Alias added: GHSA-5xp2-rv4h-mm2q

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources