Read the docs
TI-2019-07457 Aliases CVE-2019-10134GHSA-j8wr-7xxj-c2fr

Improper input validation in moodle

Priority LOW 20CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18. The size of users' private file uploads via email were not correctly checked, so their quota allowance could be exceeded.

Why it matters now

EPSS 0.0105 64th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.6.4, 3.5.6, 3.4.9 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Moodlemoodle3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18—No fix listedCNA
—moodle/moodle (Packagist)3.6 to before 3.6.43.6.4Patch availableGHSA-j8wr-7xxj-c2fr
—moodle/moodle (Packagist)3.5 to before 3.5.63.5.6Patch availableGHSA-j8wr-7xxj-c2fr
—moodle/moodle (Packagist)3.4 to before 3.4.93.4.9Patch availableGHSA-j8wr-7xxj-c2fr
—moodle/moodle (Packagist)3.1 to before 3.1.183.1.18Patch availableGHSA-j8wr-7xxj-c2fr
  • moodle VendorMoodle Affected 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.6 to before 3.6.4 Fixed in 3.6.4 Patch available GHSA-j8wr-7xxj-c2fr
  • moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.6 Fixed in 3.5.6 Patch available GHSA-j8wr-7xxj-c2fr
  • moodle/moodle (Packagist) Vendor— Affected 3.4 to before 3.4.9 Fixed in 3.4.9 Patch available GHSA-j8wr-7xxj-c2fr
  • moodle/moodle (Packagist) Vendor— Affected 3.1 to before 3.1.18 Fixed in 3.1.18 Patch available GHSA-j8wr-7xxj-c2fr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.1.0 – 3.1.17; 3.4.0 – 3.4.8; 3.5.0 – 3.5.5; 3.6.0 – 3.6.3VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.1.0 – 3.1.17; 3.4.0 – 3.4.8; 3.5.0 – 3.5.5; 3.6.0 – 3.6.3 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-j8wr-7xxj-c2fr moodle/moodle (Packagist) Fixed in 3.6.4 Advisory →
  • Fix · GHSA-j8wr-7xxj-c2fr moodle/moodle (Packagist) Fixed in 3.5.6 Advisory →
  • Fix · GHSA-j8wr-7xxj-c2fr moodle/moodle (Packagist) Fixed in 3.4.9 Advisory →
  • Fix · GHSA-j8wr-7xxj-c2fr moodle/moodle (Packagist) Fixed in 3.1.18 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10134
  2. 2026-10-03 Alias added: GHSA-j8wr-7xxj-c2fr

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources