Improper authorization in moodle
Priority LOW 36CWE-285Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
A flaw was found in Moodle before versions 3.7, 3.6.4. A web service fetching messages was not restricted to the current user's conversations.
Why it matters now
EPSS 0.01318 70th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.6.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Moodle | moodle | 3.7; 3.6.4 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.6 to before 3.6.4 | 3.6.4 | Patch available | GHSA-ww45-x87c-wgff |
- moodle VendorMoodle Affected 3.7; 3.6.4 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.6 to before 3.6.4 Fixed in 3.6.4 Patch available GHSA-ww45-x87c-wgff
Remediation
- Fix · GHSA-ww45-x87c-wgff moodle/moodle (Packagist) Fixed in 3.6.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10154
- 2026-10-03 Alias added: GHSA-ww45-x87c-wgff
References
Advisory 2
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2019-10154 · CVE Program
- CVE-2019-10154 · NVD
- FIRST EPSS
- GHSA-ww45-x87c-wgff · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10154 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences