Read the docs
TI-2019-07510 Aliases CVE-2019-10189GHSA-h7xp-7fjp-ghhc

Improper access control in moodle

Priority LOW 22CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.

Summary

A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Teachers in an assignment group could modify group overrides for other groups in the same assignment.

Why it matters now

EPSS 0.00864 58th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.7.1, 3.6.5, 3.5.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Moodlemoodle3.7.1; 3.6.5; 3.5.7—No fix listedCNA
—moodle/moodle (Packagist)3.7.0 to before 3.7.13.7.1Patch availableGHSA-h7xp-7fjp-ghhc
—moodle/moodle (Packagist)3.6.0 to before 3.6.53.6.5Patch availableGHSA-h7xp-7fjp-ghhc
—moodle/moodle (Packagist)before 3.5.73.5.7Patch availableGHSA-h7xp-7fjp-ghhc
  • moodle VendorMoodle Affected 3.7.1; 3.6.5; 3.5.7 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.7.0 to before 3.7.1 Fixed in 3.7.1 Patch available GHSA-h7xp-7fjp-ghhc
  • moodle/moodle (Packagist) Vendor— Affected 3.6.0 to before 3.6.5 Fixed in 3.6.5 Patch available GHSA-h7xp-7fjp-ghhc
  • moodle/moodle (Packagist) Vendor— Affected before 3.5.7 Fixed in 3.5.7 Patch available GHSA-h7xp-7fjp-ghhc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 3.5.7; 3.6.0 to before 3.6.5; 3.7.0 to before 3.7.1VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 3.5.7; 3.6.0 to before 3.6.5; 3.7.0 to before 3.7.1 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-h7xp-7fjp-ghhc moodle/moodle (Packagist) Fixed in 3.7.1 Advisory →
  • Fix · GHSA-h7xp-7fjp-ghhc moodle/moodle (Packagist) Fixed in 3.6.5 Advisory →
  • Fix · GHSA-h7xp-7fjp-ghhc moodle/moodle (Packagist) Fixed in 3.5.7 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10189
  2. 2026-10-03 Alias added: GHSA-h7xp-7fjp-ghhc

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources