Firefly III before 4.7.17.1 is vulnerable to stored XSS due to lack of filtration of…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Firefly III before 4.7.17.1 is vulnerable to stored XSS due to lack of filtration of user-supplied data in a budget name. The JavaScript code is contained in a transaction, and is executed on the tags/show/$tag_number$ tag summary page. NOTE: It is asserted that an attacker must have the same access rights as the user in order to be able to execute the vulnerability
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | grumpydictator/firefly-iii (Packagist) | before 4.7.17.1 | 4.7.17.1 | Patch available | GHSA-9xmx-rj7j-fv9q |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- grumpydictator/firefly-iii (Packagist) Vendor— Affected before 4.7.17.1 Fixed in 4.7.17.1 Patch available GHSA-9xmx-rj7j-fv9q
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:firefly-iii:firefly_iii:*:*:*:*:*:*:*:* | before 4.7.17.1 | Vulnerable | firefly-iii |
- cpe:2.3:a:firefly-iii:firefly_iii:*:*:*:*:*:*:*:* Versions before 4.7.17.1 Vulnerable ·firefly-iii
Remediation
- Fix · GHSA-9xmx-rj7j-fv9q grumpydictator/firefly-iii (Packagist) Fixed in 4.7.17.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-13644
- 2026-10-03 Alias added: GHSA-9xmx-rj7j-fv9q
References
More firefly-iii Firefly Iii vulnerabilities
- TI-2023-01681 Improper Input Validation in firefly-iii/firefly-iii CVSS 3.1CRITICAL 9.8
- TI-2023-01680 Insufficient Session Expiration in firefly-iii/firefly-iii CVSS 3.1CRITICAL 9.8
- TI-2023-00283 Incorrect Authorization in firefly-iii/firefly-iii CVSS 3.1MEDIUM 6.5
- TI-2021-02811 Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
- TI-2021-02777 Unrestricted Upload of File with Dangerous Type in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
- TI-2021-02750 Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
Sources
- CVE-2019-13644 · CVE Program
- CVE-2019-13644 · NVD
- FIRST EPSS
- GHSA-9xmx-rj7j-fv9q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences