Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
Why it matters now
EPSS 0.00541 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed firefly-iii/firefly-iii (firefly-iii): 5.6.1grumpydictator/firefly-iii (Packagist): 5.6.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| firefly-iii | firefly-iii/firefly-iii | before 5.6.1 | 5.6.1 | Patch available | CNA |
| — | grumpydictator/firefly-iii (Packagist) | before 5.6.1 | 5.6.1 | Patch available | GHSA-356r-77q8-f64f |
- firefly-iii/firefly-iii Vendorfirefly-iii Affected before 5.6.1 Fixed in 5.6.1 Patch available CNA
- grumpydictator/firefly-iii (Packagist) Vendor— Affected before 5.6.1 Fixed in 5.6.1 Patch available GHSA-356r-77q8-f64f
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:firefly-iii:firefly_iii:*:*:*:*:*:*:*:* | before 5.6.1 | Vulnerable | firefly-iii |
- cpe:2.3:a:firefly-iii:firefly_iii:*:*:*:*:*:*:*:* Versions before 5.6.1 Vulnerable ·firefly-iii
Remediation
- Fix · CNA firefly-iii/firefly-iii (firefly-iii) Fixed in 5.6.1
- Fix · GHSA-356r-77q8-f64f grumpydictator/firefly-iii (Packagist) Fixed in 5.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3819
- 2026-10-03 Alias added: GHSA-356r-77q8-f64f
References
More firefly-iii Firefly Iii vulnerabilities
- TI-2023-01681 Improper Input Validation in firefly-iii/firefly-iii CVSS 3.1CRITICAL 9.8
- TI-2023-01680 Insufficient Session Expiration in firefly-iii/firefly-iii CVSS 3.1CRITICAL 9.8
- TI-2023-00283 Incorrect Authorization in firefly-iii/firefly-iii CVSS 3.1MEDIUM 6.5
- TI-2019-10251 Firefly III before 4.7.17.1 is vulnerable to stored XSS due to lack of filtration of… CVSS 3.1MEDIUM 5.4
- TI-2021-02811 Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
- TI-2021-02777 Unrestricted Upload of File with Dangerous Type in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
Sources
- CVE-2021-3819 · CVE Program
- CVE-2021-3819 · NVD
- FIRST EPSS
- GHSA-356r-77q8-f64f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences