Improper Input Validation in firefly-iii/firefly-iii
Priority HIGH 75CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Improper Input Validation in GitHub repository firefly-iii/firefly-iii prior to 6.0.0.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00335 27th percentileScored 2026-11-07
Fix Fixed firefly-iii/firefly-iii (firefly-iii): 6.0.0grumpydictator/firefly-iii (Packagist): 6.0.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| firefly-iii | firefly-iii/firefly-iii | before 6.0.0 | 6.0.0 | Patch available | CNA |
| — | grumpydictator/firefly-iii (Packagist) | before 6.0.0 | 6.0.0 | Patch available | GHSA-mwxw-hxvp-4r2r |
- firefly-iii/firefly-iii Vendorfirefly-iii Affected before 6.0.0 Fixed in 6.0.0 Patch available CNA
- grumpydictator/firefly-iii (Packagist) Vendor— Affected before 6.0.0 Fixed in 6.0.0 Patch available GHSA-mwxw-hxvp-4r2r
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:firefly-iii:firefly_iii:*:*:*:*:*:*:*:* | before 5.7.18 | Vulnerable | firefly-iii |
| cpe:2.3:a:firefly-iii:firefly_iii:5.8.0:alpha1:*:*:*:*:*:* | 5.8.0 alpha1 | Vulnerable | firefly-iii |
| cpe:2.3:a:firefly-iii:firefly_iii:6.0.0:alpha1:*:*:*:*:*:* | 6.0.0 alpha1 | Vulnerable | firefly-iii |
| cpe:2.3:a:firefly-iii:firefly_iii:6.0.0:alpha2:*:*:*:*:*:* | 6.0.0 alpha2 | Vulnerable | firefly-iii |
| cpe:2.3:a:firefly-iii:firefly_iii:6.0.0:beta1:*:*:*:*:*:* | 6.0.0 beta1 | Vulnerable | firefly-iii |
- cpe:2.3:a:firefly-iii:firefly_iii:*:*:*:*:*:*:*:* Versions before 5.7.18 Vulnerable ·firefly-iii
- cpe:2.3:a:firefly-iii:firefly_iii:5.8.0:alpha1:*:*:*:*:*:* Versions 5.8.0 alpha1 Vulnerable ·firefly-iii
- cpe:2.3:a:firefly-iii:firefly_iii:6.0.0:alpha1:*:*:*:*:*:* Versions 6.0.0 alpha1 Vulnerable ·firefly-iii
- cpe:2.3:a:firefly-iii:firefly_iii:6.0.0:alpha2:*:*:*:*:*:* Versions 6.0.0 alpha2 Vulnerable ·firefly-iii
- cpe:2.3:a:firefly-iii:firefly_iii:6.0.0:beta1:*:*:*:*:*:* Versions 6.0.0 beta1 Vulnerable ·firefly-iii
Remediation
- Fix · CNA firefly-iii/firefly-iii (firefly-iii) Fixed in 6.0.0
- Fix · GHSA-mwxw-hxvp-4r2r grumpydictator/firefly-iii (Packagist) Fixed in 6.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1789
- 2026-10-03 Alias added: GHSA-mwxw-hxvp-4r2r
References
More firefly-iii Firefly Iii vulnerabilities
- TI-2023-01680 Insufficient Session Expiration in firefly-iii/firefly-iii CVSS 3.1CRITICAL 9.8
- TI-2023-00283 Incorrect Authorization in firefly-iii/firefly-iii CVSS 3.1MEDIUM 6.5
- TI-2019-10251 Firefly III before 4.7.17.1 is vulnerable to stored XSS due to lack of filtration of… CVSS 3.1MEDIUM 5.4
- TI-2021-02811 Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
- TI-2021-02777 Unrestricted Upload of File with Dangerous Type in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
- TI-2021-02750 Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
Sources
- CVE-2023-1789 · CVE Program
- CVE-2023-1789 · NVD
- FIRST EPSS
- GHSA-mwxw-hxvp-4r2r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences