YOURLS through 1.7.3 is affected by a type juggling vulnerability in the api component that can result in login bypass.
Priority MEDIUM 51CWE-843Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-843 and the CVSS impact.
Summary
YOURLS through 1.7.3 is affected by a type juggling vulnerability in the api component that can result in login bypass.
Why it matters now
EPSS 0.06145 93rd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed yourls/yourls (Packagist): 1.7.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | yourls/yourls (Packagist) | before 1.7.4 | 1.7.4 | Patch available | GHSA-vf23-f26f-mjj9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- yourls/yourls (Packagist) Vendor— Affected before 1.7.4 Fixed in 1.7.4 Patch available GHSA-vf23-f26f-mjj9
Remediation
- Fix · GHSA-vf23-f26f-mjj9 yourls/yourls (Packagist) Fixed in 1.7.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-14537
- 2026-10-03 Alias added: GHSA-vf23-f26f-mjj9
References
Exploit 2
Advisory 3
More Yourls vulnerabilities
- TI-2021-02667 Improper Restriction of Rendered UI Layers or Frames in yourls/yourls CVSS 3.1HIGH 8.8
- TI-2022-00039 Cross-Site Request Forgery (CSRF) in yourls/yourls CVSS 3.1HIGH 7.4
- TI-2021-02714 Cross-site Scripting (XSS) - Reflected in yourls/yourls CVSS 3.1MEDIUM 6.1
- TI-2021-02716 Cross-site Scripting (XSS) - Stored in yourls/yourls CVSS 3.1MEDIUM 5.4
- TI-2020-16654 Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin… CVSS 3.1MEDIUM 5.4
- TI-2011-03381 Your Own URL Shortener (YOURLS) 1.5 allows remote attackers to obtain sensitive… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2019-14537 · CVE Program
- CVE-2019-14537 · NVD
- FIRST EPSS
- GHSA-vf23-f26f-mjj9 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-14537 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences