Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin…
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin Panel, Versions 1.5 - 1.7.10. An authenticated user must modify a PHP plugin with a malicious payload and upload it, resulting in multiple stored XSS issues.
Why it matters now
EPSS 0.00715 53rd percentileScored 2026-11-07
Fix Fixed yourls/yourls (Packagist): 1.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | yourls/yourls (Packagist) | 1.5 to before 1.8 | 1.8 | Patch available | GHSA-pwgg-r6fq-mf94 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- yourls/yourls (Packagist) Vendor— Affected 1.5 to before 1.8 Fixed in 1.8 Patch available GHSA-pwgg-r6fq-mf94
Remediation
- Fix · GHSA-pwgg-r6fq-mf94 yourls/yourls (Packagist) Fixed in 1.8 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-27388
- 2026-10-03 Alias added: GHSA-pwgg-r6fq-mf94
References
Advisory 3
More Yourls vulnerabilities
- TI-2019-10834 YOURLS through 1.7.3 is affected by a type juggling vulnerability in the api component that can result in login bypass. CVSS 3.0CRITICAL 9.8
- TI-2021-02667 Improper Restriction of Rendered UI Layers or Frames in yourls/yourls CVSS 3.1HIGH 8.8
- TI-2022-00039 Cross-Site Request Forgery (CSRF) in yourls/yourls CVSS 3.1HIGH 7.4
- TI-2021-02714 Cross-site Scripting (XSS) - Reflected in yourls/yourls CVSS 3.1MEDIUM 6.1
- TI-2021-02716 Cross-site Scripting (XSS) - Stored in yourls/yourls CVSS 3.1MEDIUM 5.4
- TI-2011-03381 Your Own URL Shortener (YOURLS) 1.5 allows remote attackers to obtain sensitive… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2020-27388 · CVE Program
- CVE-2020-27388 · NVD
- FIRST EPSS
- GHSA-pwgg-r6fq-mf94 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-27388 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences