Cross-site Scripting (XSS) - Stored in yourls/yourls
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
yourls is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Why it matters now
EPSS 0.00721 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed yourls/yourls (yourls): 1.8.2yourls/yourls (Packagist): 1.8.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| yourls | yourls/yourls | before 1.8.2 | 1.8.2 | Patch available | CNA |
| — | yourls/yourls (Packagist) | before 1.8.2 | 1.8.2 | Patch available | GHSA-m9fq-c9hp-59g7 |
- yourls/yourls Vendoryourls Affected before 1.8.2 Fixed in 1.8.2 Patch available CNA
- yourls/yourls (Packagist) Vendor— Affected before 1.8.2 Fixed in 1.8.2 Patch available GHSA-m9fq-c9hp-59g7
Remediation
- Fix · CNA yourls/yourls (yourls) Fixed in 1.8.2
- Fix · GHSA-m9fq-c9hp-59g7 yourls/yourls (Packagist) Fixed in 1.8.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3785
- 2026-10-03 Alias added: GHSA-m9fq-c9hp-59g7
References
More Yourls vulnerabilities
- TI-2019-10834 YOURLS through 1.7.3 is affected by a type juggling vulnerability in the api component that can result in login bypass. CVSS 3.0CRITICAL 9.8
- TI-2021-02667 Improper Restriction of Rendered UI Layers or Frames in yourls/yourls CVSS 3.1HIGH 8.8
- TI-2022-00039 Cross-Site Request Forgery (CSRF) in yourls/yourls CVSS 3.1HIGH 7.4
- TI-2021-02714 Cross-site Scripting (XSS) - Reflected in yourls/yourls CVSS 3.1MEDIUM 6.1
- TI-2020-16654 Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin… CVSS 3.1MEDIUM 5.4
- TI-2011-03381 Your Own URL Shortener (YOURLS) 1.5 allows remote attackers to obtain sensitive… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2021-3785 · CVE Program
- CVE-2021-3785 · NVD
- FIRST EPSS
- GHSA-m9fq-c9hp-59g7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences