Firefly III 4.7.17.3 is vulnerable to local file enumeration.
Priority LOW 16CWE-20Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Firefly III 4.7.17.3 is vulnerable to local file enumeration. An attacker can enumerate local files due to the lack of protocol scheme sanitization, such as for file:/// URLs. This is related to fints_url to import/job/configuration, and import/create/fints.
Why it matters now
EPSS 0.00472 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed grumpydictator/firefly-iii (Packagist): 4.7.17.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | grumpydictator/firefly-iii (Packagist) | before 4.7.17.4 | 4.7.17.4 | Patch available | GHSA-jjcx-999m-35hc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- grumpydictator/firefly-iii (Packagist) Vendor— Affected before 4.7.17.4 Fixed in 4.7.17.4 Patch available GHSA-jjcx-999m-35hc
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:firefly-iii:firefly_iii:4.7.17.3:*:*:*:*:*:*:* | 4.7.17.3 | Vulnerable | firefly-iii |
- cpe:2.3:a:firefly-iii:firefly_iii:4.7.17.3:*:*:*:*:*:*:* Versions 4.7.17.3 Vulnerable ·firefly-iii
Remediation
- Fix · GHSA-jjcx-999m-35hc grumpydictator/firefly-iii (Packagist) Fixed in 4.7.17.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-14671
- 2026-10-03 Alias added: GHSA-jjcx-999m-35hc
References
More firefly-iii Firefly Iii vulnerabilities
- TI-2023-01681 Improper Input Validation in firefly-iii/firefly-iii CVSS 3.1CRITICAL 9.8
- TI-2023-01680 Insufficient Session Expiration in firefly-iii/firefly-iii CVSS 3.1CRITICAL 9.8
- TI-2023-00283 Incorrect Authorization in firefly-iii/firefly-iii CVSS 3.1MEDIUM 6.5
- TI-2019-10251 Firefly III before 4.7.17.1 is vulnerable to stored XSS due to lack of filtration of… CVSS 3.1MEDIUM 5.4
- TI-2021-02811 Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
- TI-2021-02777 Unrestricted Upload of File with Dangerous Type in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
Sources
- CVE-2019-14671 · CVE Program
- CVE-2019-14671 · NVD
- FIRST EPSS
- GHSA-jjcx-999m-35hc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences