Access control flaw in [UNKNOWN] moodle
Priority LOW 26CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
A vulnerability was found in Moodle versions 3.7.x before 3.7.3, 3.6.x before 3.6.7 and 3.5.x before 3.5.9. When a cohort role assignment was removed, the associated capabilities were not being revoked (where applicable).
Why it matters now
EPSS 0.00709 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed moodle ([UNKNOWN]): 3.7.3, 3.6.7, 3.5.9moodle/moodle (Packagist): 3.7.3, 3.6.7, 3.5.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| [UNKNOWN] | moodle | 3.7 to before 3.7.3; 3.6 to before 3.6.7; 3.5 to before 3.5.9 | 3.7.3, 3.6.7, 3.5.9 | Patch available | CNA |
| — | moodle/moodle (Packagist) | 3.7.0 to before 3.7.3 | 3.7.3 | Patch available | GHSA-g9m2-c2x5-fr2v |
| — | moodle/moodle (Packagist) | 3.6.0 to before 3.6.7 | 3.6.7 | Patch available | GHSA-g9m2-c2x5-fr2v |
| — | moodle/moodle (Packagist) | 3.5.0 to before 3.5.9 | 3.5.9 | Patch available | GHSA-g9m2-c2x5-fr2v |
- moodle Vendor[UNKNOWN] Affected 3.7 to before 3.7.3; 3.6 to before 3.6.7; 3.5 to before 3.5.9 Fixed in 3.7.3, 3.6.7, 3.5.9 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected 3.7.0 to before 3.7.3 Fixed in 3.7.3 Patch available GHSA-g9m2-c2x5-fr2v
- moodle/moodle (Packagist) Vendor— Affected 3.6.0 to before 3.6.7 Fixed in 3.6.7 Patch available GHSA-g9m2-c2x5-fr2v
- moodle/moodle (Packagist) Vendor— Affected 3.5.0 to before 3.5.9 Fixed in 3.5.9 Patch available GHSA-g9m2-c2x5-fr2v
Remediation
- Fix · CNA moodle ([UNKNOWN]) Fixed in 3.7.3, 3.6.7, 3.5.9
- Fix · GHSA-g9m2-c2x5-fr2v moodle/moodle (Packagist) Fixed in 3.7.3 Advisory →
- Fix · GHSA-g9m2-c2x5-fr2v moodle/moodle (Packagist) Fixed in 3.6.7 Advisory →
- Fix · GHSA-g9m2-c2x5-fr2v moodle/moodle (Packagist) Fixed in 3.5.9 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-14879
- 2026-10-03 Alias added: GHSA-g9m2-c2x5-fr2v
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2019-14879 · CVE Program
- CVE-2019-14879 · NVD
- FIRST EPSS
- GHSA-g9m2-c2x5-fr2v · GitHub Advisory Database · CC BY 4.0
- CVE-2019-14879 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences