Improper authorization in [UNKNOWN] moodle
Priority LOW 26CWE-285Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
A vulnerability was found in Moodle 3.6 before 3.6.7 and 3.7 before 3.7.3, where tokens used to fetch inline atachments in email notifications were not disabled when a user's account was no longer active. Note: to access files, a user would need to know the file path, and their token.
Why it matters now
EPSS 0.01094 65th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.6.7, 3.7.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| [UNKNOWN] | moodle | 3.7.3; 3.6.7 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.6 to before 3.6.7 | 3.6.7 | Patch available | GHSA-774q-wfcp-vc2q |
| — | moodle/moodle (Packagist) | 3.7 to before 3.7.3 | 3.7.3 | Patch available | GHSA-774q-wfcp-vc2q |
- moodle Vendor[UNKNOWN] Affected 3.7.3; 3.6.7 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.6 to before 3.6.7 Fixed in 3.6.7 Patch available GHSA-774q-wfcp-vc2q
- moodle/moodle (Packagist) Vendor— Affected 3.7 to before 3.7.3 Fixed in 3.7.3 Patch available GHSA-774q-wfcp-vc2q
Remediation
- Fix · GHSA-774q-wfcp-vc2q moodle/moodle (Packagist) Fixed in 3.6.7 Advisory →
- Fix · GHSA-774q-wfcp-vc2q moodle/moodle (Packagist) Fixed in 3.7.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-14883
- 2026-10-03 Alias added: GHSA-774q-wfcp-vc2q
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2019-14883 · CVE Program
- CVE-2019-14883 · NVD
- FIRST EPSS
- GHSA-774q-wfcp-vc2q · GitHub Advisory Database · CC BY 4.0
- CVE-2019-14883 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences