Read the docs
TI-2019-11088 Aliases CVE-2019-14884GHSA-3xh5-5v5v-mfgm

Cross-site scripting in [UNKNOWN] moodle

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A vulnerability was found in Moodle 3.7 before 3.73, 3.6 before 3.6.7 and 3.5 before 3.5.9, where a reflected XSS possible from some fatal error messages.

Why it matters now

EPSS 0.00932 60th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.7.3, 3.6.7, 3.5.9

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
[UNKNOWN]moodle3.7.3; 3.6.7; 3.5.9—No fix listedCNA
—moodle/moodle (Packagist)3.7.0 to before 3.7.33.7.3Patch availableGHSA-3xh5-5v5v-mfgm
—moodle/moodle (Packagist)3.6.0 to before 3.6.73.6.7Patch availableGHSA-3xh5-5v5v-mfgm
—moodle/moodle (Packagist)3.5.0 to before 3.5.93.5.9Patch availableGHSA-3xh5-5v5v-mfgm
  • moodle Vendor[UNKNOWN] Affected 3.7.3; 3.6.7; 3.5.9 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.7.0 to before 3.7.3 Fixed in 3.7.3 Patch available GHSA-3xh5-5v5v-mfgm
  • moodle/moodle (Packagist) Vendor— Affected 3.6.0 to before 3.6.7 Fixed in 3.6.7 Patch available GHSA-3xh5-5v5v-mfgm
  • moodle/moodle (Packagist) Vendor— Affected 3.5.0 to before 3.5.9 Fixed in 3.5.9 Patch available GHSA-3xh5-5v5v-mfgm

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.5.0 to before 3.5.9; 3.6.0 to before 3.6.7; 3.7.0 – 3.7.3VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.5.0 to before 3.5.9; 3.6.0 to before 3.6.7; 3.7.0 – 3.7.3 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-3xh5-5v5v-mfgm moodle/moodle (Packagist) Fixed in 3.7.3 Advisory →
  • Fix · GHSA-3xh5-5v5v-mfgm moodle/moodle (Packagist) Fixed in 3.6.7 Advisory →
  • Fix · GHSA-3xh5-5v5v-mfgm moodle/moodle (Packagist) Fixed in 3.5.9 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-14884
  2. 2026-10-03 Alias added: GHSA-3xh5-5v5v-mfgm

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources