In Octopus Deploy 2019.7.3 through 2019.7.9, in certain circumstances, an authenticated…
Priority LOW 22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
In Octopus Deploy 2019.7.3 through 2019.7.9, in certain circumstances, an authenticated user with VariableView permissions could view sensitive values. This is fixed in 2019.7.10.
Why it matters now
EPSS 0.00879 59th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | 2019.7.3 – 2019.7.9 | Vulnerable | Octopus Deploy |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions 2019.7.3 – 2019.7.9 Vulnerable ·Octopus Deploy
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2019-15698
- 2026-10-03 Alias added: GHSA-8xgg-pj9m-c8xj
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
Sources
- CVE-2019-15698 · CVE Program
- CVE-2019-15698 · NVD
- FIRST EPSS
- GHSA-8xgg-pj9m-c8xj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences