Read the docs
TI-2019-11973 Aliases CVE-2019-15929GHSA-wvr4-w6cw-4px8

In Craft CMS through 3.1.7, the elevated session password prompt was not being rate…

Priority MEDIUM 46CWE-640Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-640.

Summary

In Craft CMS through 3.1.7, the elevated session password prompt was not being rate limited like normal login forms, leading to the possibility of a brute force attempt on them.

Why it matters now

EPSS 0.01753 78th percentileScored 2026-11-07
Fix Fixed craftcms/cms (Packagist): 3.1.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—craftcms/cms (Packagist)before 3.1.73.1.7Patch availableGHSA-wvr4-w6cw-4px8
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • craftcms/cms (Packagist) Vendor— Affected before 3.1.7 Fixed in 3.1.7 Patch available GHSA-wvr4-w6cw-4px8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:*up to 3.1.7VulnerableCraft CMS
  • cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions up to 3.1.7 Vulnerable ·Craft CMS

Remediation

  • Fix · GHSA-wvr4-w6cw-4px8 craftcms/cms (Packagist) Fixed in 3.1.7 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-15929
  2. 2026-10-03 Alias added: GHSA-wvr4-w6cw-4px8

References

  • TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
  • TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
  • TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
  • TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
See all 96 →

Sources