Read the docs
TI-2019-12101 Aliases CVE-2019-16108GHSA-8hc2-hvrc-x4qr

phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.

Priority LOW 35CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.

Why it matters now

EPSS 0.01077 65th percentileScored 2026-11-07
Fix Fixed phpbb/phpbb (Packagist): 3.2.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—phpbb/phpbb (Packagist)3.2.7 to before 3.2.83.2.8Patch availableGHSA-8hc2-hvrc-x4qr
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • phpbb/phpbb (Packagist) Vendor— Affected 3.2.7 to before 3.2.8 Fixed in 3.2.8 Patch available GHSA-8hc2-hvrc-x4qr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpbb:phpbb:3.2.7:*:*:*:*:*:*:*3.2.7VulnerablephpBB
  • cpe:2.3:a:phpbb:phpbb:3.2.7:*:*:*:*:*:*:* Versions 3.2.7 Vulnerable ·phpBB

Remediation

  • Fix · GHSA-8hc2-hvrc-x4qr phpbb/phpbb (Packagist) Fixed in 3.2.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-16108
  2. 2026-10-03 Alias added: GHSA-8hc2-hvrc-x4qr

References

  • TI-2025-43137 Cross Site Request Forgery vulnerability in Phpbb phbb3 v.3.3.15 allows a local attacker… CVSS 3.1HIGH 8.8
  • TI-2001-01423 prefs.php in phpBB 1.4.0 and earlier allows remote authenticated users to execute… CVSS 3.1HIGH 8.8
  • TI-2008-03086 Unspecified vulnerability in phpBB before 3.0.1 has unknown impact and attack vectors… CVSS 2.0HIGH 10.0
  • TI-2008-01694 Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack… CVSS 2.0HIGH 10.0
  • TI-2006-06909 PHP remote file inclusion vulnerability in includes/not_mem.php in the Add Name module… CVSS 2.0HIGH 7.5
  • TI-2019-12678 In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a… CVSS 3.1HIGH 8.8
See all 37 →

Sources