XSS in Pannellum from 2.5.0 through 2.5.4
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Pannellum from 2.5.0 through 2.5.4 URLs were not sanitized for data URIs (or vbscript:), allowing for potential XSS attacks. Such an attack would require a user to click on a hot spot to execute and would require an attacker-provided configuration. The most plausible potential attack would be if pannellum.htm was hosted on a domain that shared cookies with the targeted site's user authentication; an <iframe> could then be embedded on the attacker's site using pannellum.htm from the targeted site, which would allow the attacker to potentially access information from the targeted site as the authenticated user (or worse if the targeted site did not have adequate CSRF protections) if the user clicked on a hot spot in the attacker's embedded panorama viewer. This was patched in version 2.5.5.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| mpretroff | pannellum | 2.5.0; 2.5.1; 2.5.2; 2.5.3; 2.5.4 | — | No fix listed | CNA |
| — | pannellum (npm) | 2.5.0 to before 2.5.5 | 2.5.5 | Patch available | GHSA-m52x-29pq-w3vv |
- pannellum Vendormpretroff Affected 2.5.0; 2.5.1; 2.5.2; 2.5.3; 2.5.4 Fixed in — No fix listed CNA
- pannellum (npm) Vendor— Affected 2.5.0 to before 2.5.5 Fixed in 2.5.5 Patch available GHSA-m52x-29pq-w3vv
Remediation
- Fix · GHSA-m52x-29pq-w3vv pannellum (npm) Fixed in 2.5.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-16763
- 2026-10-03 Alias added: GHSA-m52x-29pq-w3vv
References
Advisory 3
More Pannellum vulnerabilities
- TI-2026-21643 Pannellum has a XSS vulnerability in hot spot attributes CVSS 4.0MEDIUM 5.3
Sources
- CVE-2019-16763 · CVE Program
- CVE-2019-16763 · NVD
- FIRST EPSS
- GHSA-m52x-29pq-w3vv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences