Pannellum has a XSS vulnerability in hot spot attributes
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Pannellum is a lightweight, free, and open source panorama viewer for the web. In versions 3.5.0 through 2.5.6, the hot spot attributes configuration property allowed any attribute to be set, including HTML event handler attributes, allowing for potential XSS attacks. This affects websites hosting the standalone viewer HTML file and any other use of untrusted JSON config files (bypassing the protections of the escapeHTML parameter). As certain events fire without any additional user interaction, visiting a standalone viewer URL that points to a malicious config file — without additional user interaction — is sufficient to trigger the vulnerability and execute arbitrary JavaScript code, which can, for example, replace the contents of the page with arbitrary content and make it appear to be hosted by the website hosting the standalone viewer HTML file. This issue has been fixed in version 2.5.7. To workaround, setting the Content-Security-Policy header to script-src-attr 'none' will block execution of inline event handlers, mitigating this vulnerability. Don't host pannellum.htm on a domain that shares cookies with user authentication to mitigate XSS risk.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| mpetroff | pannellum | 2.5.0 to before 2.5.7 | 2.5.7 | Patch available | CNA |
| — | pannellum (npm) | 2.5.0 to before 2.5.7 | 2.5.7 | Patch available | GHSA-8423-w5wx-h2r6 |
- pannellum Vendormpetroff Affected 2.5.0 to before 2.5.7 Fixed in 2.5.7 Patch available CNA
- pannellum (npm) Vendor— Affected 2.5.0 to before 2.5.7 Fixed in 2.5.7 Patch available GHSA-8423-w5wx-h2r6
Remediation
- Fix · CNA pannellum (mpetroff) Fixed in 2.5.7
- Fix · GHSA-8423-w5wx-h2r6 pannellum (npm) Fixed in 2.5.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-27210
- 2026-10-03 Alias added: GHSA-8423-w5wx-h2r6
References
More Pannellum vulnerabilities
- TI-2019-12544 XSS in Pannellum from 2.5.0 through 2.5.4 CVSS 3.1MEDIUM 6.1
Sources
- CVE-2026-27210 · CVE Program
- CVE-2026-27210 · NVD
- FIRST EPSS
- GHSA-8423-w5wx-h2r6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences