Automattic Mongoose through 5.7.4 allows attackers to bypass access control (in some…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Automattic Mongoose through 5.7.4 allows attackers to bypass access control (in some applications) because any query object with a _bsontype attribute is ignored. For example, adding "_bsontype":"a" can sometimes interfere with a query filter. NOTE: this CVE is about Mongoose's failure to work around this _bsontype special case that exists in older versions of the bson parser (aka the mongodb/js-bson project).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mongoose (npm) | 5.0.0 to before 5.7.5 | 5.7.5 | Patch available | GHSA-8687-vv9j-hgph |
| — | mongoose (npm) | before 4.13.21 | 4.13.21 | Patch available | GHSA-8687-vv9j-hgph |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mongoose (npm) Vendor— Affected 5.0.0 to before 5.7.5 Fixed in 5.7.5 Patch available GHSA-8687-vv9j-hgph
- mongoose (npm) Vendor— Affected before 4.13.21 Fixed in 4.13.21 Patch available GHSA-8687-vv9j-hgph
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:* | up to 5.7.4 | Vulnerable | mongoosejs |
- cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:* Versions up to 5.7.4 Vulnerable ·mongoosejs
Remediation
- Fix · GHSA-8687-vv9j-hgph mongoose (npm) Fixed in 5.7.5 Advisory →
- Fix · GHSA-8687-vv9j-hgph mongoose (npm) Fixed in 4.13.21 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-17426
- 2026-10-03 Alias added: GHSA-8687-vv9j-hgph
References
Advisory 2
More mongoosejs Mongoose vulnerabilities
- TI-2023-03453 Prototype Pollution in automattic/mongoose CVSS 3.1CRITICAL 9.8
- TI-2022-02368 Prototype Pollution in automattic/mongoose CVSS 3.1CRITICAL 9.8
- TI-2024-36076 Mongoose before 8.8.3 can improperly use $where in match, leading to search injection. CVSS 3.1CRITICAL 9.1
- TI-2025-16870 Code injection in mongoosejs Mongoose CVSS 3.1CRITICAL 9.8
- TI-2026-30638 Mongoose: Improper Sanitization of $nor in sanitizeFilter May Allow NoSQL Injection CVSS 3.1HIGH 7.5
Sources
- CVE-2019-17426 · CVE Program
- CVE-2019-17426 · NVD
- FIRST EPSS
- GHSA-8687-vv9j-hgph · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences