Prototype Pollution in automattic/mongoose
Priority HIGH 81CWE-1321Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Prototype Pollution in GitHub repository automattic/mongoose prior to 7.3.4.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01208 68th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed automattic/mongoose (automattic): 7.3.4mongoose (npm): 7.3.3, 6.11.3, 5.13.20
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Automattic | automattic/mongoose | before 7.3.4 | 7.3.4 | Patch available | CNA |
| — | mongoose (npm) | 7.0.0 to before 7.3.3 | 7.3.3 | Patch available | GHSA-9m93-w8w6-76hh |
| — | mongoose (npm) | 6.0.0 to before 6.11.3 | 6.11.3 | Patch available | GHSA-9m93-w8w6-76hh |
| — | mongoose (npm) | before 5.13.20 | 5.13.20 | Patch available | GHSA-9m93-w8w6-76hh |
- automattic/mongoose VendorAutomattic Affected before 7.3.4 Fixed in 7.3.4 Patch available CNA
- mongoose (npm) Vendor— Affected 7.0.0 to before 7.3.3 Fixed in 7.3.3 Patch available GHSA-9m93-w8w6-76hh
- mongoose (npm) Vendor— Affected 6.0.0 to before 6.11.3 Fixed in 6.11.3 Patch available GHSA-9m93-w8w6-76hh
- mongoose (npm) Vendor— Affected before 5.13.20 Fixed in 5.13.20 Patch available GHSA-9m93-w8w6-76hh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:* | before 5.13.20; 6.0.0 to before 6.11.3; 7.0.0 to before 7.3.4 | Vulnerable | mongoosejs |
- cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:* Versions before 5.13.20; 6.0.0 to before 6.11.3; 7.0.0 to before 7.3.4 Vulnerable ·mongoosejs
Remediation
- Fix · CNA automattic/mongoose (automattic) Fixed in 7.3.4
- Fix · GHSA-9m93-w8w6-76hh mongoose (npm) Fixed in 7.3.3 Advisory →
- Fix · GHSA-9m93-w8w6-76hh mongoose (npm) Fixed in 6.11.3 Advisory →
- Fix · GHSA-9m93-w8w6-76hh mongoose (npm) Fixed in 5.13.20 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3696
- 2026-10-03 Alias added: GHSA-9m93-w8w6-76hh
References
More Automattic vulnerabilities
- TI-2023-12700 Improper authentication in WooCommerce Payments WordPress Plugin CVSS 3.1CRITICAL 9.8
- TI-2024-06106 Jetpack Boost < 3.4.7 - Admin+ SSRF CVSS 3.1CRITICAL 9.1
- TI-2013-01782 WordPress W3 Total Cache Plugin 0.9.2.8 has a Remote PHP Code Execution Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-02368 Prototype Pollution in automattic/mongoose CVSS 3.1CRITICAL 9.8
- TI-2023-02806 Jetpack < 12.1.1 - Author+ Arbitrary File Manipulation via API CVSS 3.1HIGH 8.8
- TI-2026-03776 ActivityPub Routing < 8.0.2 - Unauthenticated Drafts/Scheduled/Pending Posts Disclosure CVSS 3.1HIGH 7.5
Sources
- CVE-2023-3696 · CVE Program
- CVE-2023-3696 · NVD
- FIRST EPSS
- GHSA-9m93-w8w6-76hh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences