Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.
Priority MEDIUM 54CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.03981 90th percentileScored 2026-11-07
Fix Fixed mongoose (npm): 8.8.3, 7.8.3, 6.13.5 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mongoose (npm) | 8.0.0-rc0 to before 8.8.3 | 8.8.3 | Patch available | GHSA-m7xq-9374-9rvx |
| — | mongoose (npm) | 7.0.0-rc0 to before 7.8.3 | 7.8.3 | Patch available | GHSA-m7xq-9374-9rvx |
| — | mongoose (npm) | 6.0.0-rc0 to before 6.13.5 | 6.13.5 | Patch available | GHSA-m7xq-9374-9rvx |
| — | mongoose (npm) | 3.6.0-rc0 to before 5.13.23 | 5.13.23 | Patch available | GHSA-m7xq-9374-9rvx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mongoose (npm) Vendor— Affected 8.0.0-rc0 to before 8.8.3 Fixed in 8.8.3 Patch available GHSA-m7xq-9374-9rvx
- mongoose (npm) Vendor— Affected 7.0.0-rc0 to before 7.8.3 Fixed in 7.8.3 Patch available GHSA-m7xq-9374-9rvx
- mongoose (npm) Vendor— Affected 6.0.0-rc0 to before 6.13.5 Fixed in 6.13.5 Patch available GHSA-m7xq-9374-9rvx
- mongoose (npm) Vendor— Affected 3.6.0-rc0 to before 5.13.23 Fixed in 5.13.23 Patch available GHSA-m7xq-9374-9rvx
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:* | before 6.13.5; 7.0.1 to before 7.8.3; 8.0.1 to before 8.8.3 | Vulnerable | mongoosejs |
| cpe:2.3:a:mongoosejs:mongoose:7.0.0:rc0:*:*:*:node.js:*:* | 7.0.0 rc0 | Vulnerable | mongoosejs |
| cpe:2.3:a:mongoosejs:mongoose:8.0.0:rc0:*:*:*:node.js:*:* | 8.0.0 rc0 | Vulnerable | mongoosejs |
- cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:* Versions before 6.13.5; 7.0.1 to before 7.8.3; 8.0.1 to before 8.8.3 Vulnerable ·mongoosejs
- cpe:2.3:a:mongoosejs:mongoose:7.0.0:rc0:*:*:*:node.js:*:* Versions 7.0.0 rc0 Vulnerable ·mongoosejs
- cpe:2.3:a:mongoosejs:mongoose:8.0.0:rc0:*:*:*:node.js:*:* Versions 8.0.0 rc0 Vulnerable ·mongoosejs
Remediation
- Fix · GHSA-m7xq-9374-9rvx mongoose (npm) Fixed in 8.8.3 Advisory →
- Fix · GHSA-m7xq-9374-9rvx mongoose (npm) Fixed in 7.8.3 Advisory →
- Fix · GHSA-m7xq-9374-9rvx mongoose (npm) Fixed in 6.13.5 Advisory →
- Fix · GHSA-m7xq-9374-9rvx mongoose (npm) Fixed in 5.13.23 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-53900
- 2026-10-03 Alias added: GHSA-m7xq-9374-9rvx
References
Advisory 2
Other 11
- https://www.npmjs.com/package/mongoose?activeTab=versions
- https://github.com/Automattic/mongoose/releases
- https://github.com/Automattic/mongoose/blob/master/CHANGELOG.md
- https://github.com/github/advisory-database/pull/6769
- https://github.com/github/advisory-database/pull/6776
- https://github.com/Automattic/mongoose/commit/33679bcf8ca43d74e3e8ecd4cc224826772d805b
- https://github.com/Automattic/mongoose/commit/bbb6fa7ecb44bbaf5bea955d886378a1247bce0b
- https://github.com/Automattic/mongoose
- https://github.com/Automattic/mongoose/compare/6.13.4...6.13.5
- https://github.com/Automattic/mongoose/compare/7.8.2...7.8.3
- https://github.com/Automattic/mongoose/compare/8.8.2...8.8.3
More mongoosejs Mongoose vulnerabilities
- TI-2023-03453 Prototype Pollution in automattic/mongoose CVSS 3.1CRITICAL 9.8
- TI-2022-02368 Prototype Pollution in automattic/mongoose CVSS 3.1CRITICAL 9.8
- TI-2025-16870 Code injection in mongoosejs Mongoose CVSS 3.1CRITICAL 9.8
- TI-2019-13012 Automattic Mongoose through 5.7.4 allows attackers to bypass access control (in some… CVSS 3.1CRITICAL 9.1
- TI-2026-30638 Mongoose: Improper Sanitization of $nor in sanitizeFilter May Allow NoSQL Injection CVSS 3.1HIGH 7.5
Sources
- CVE-2024-53900 · CVE Program
- CVE-2024-53900 · NVD
- FIRST EPSS
- GHSA-m7xq-9374-9rvx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences