Cross-site scripting in Apache Syncope
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
It was found that the Apache Syncope EndUser UI login page prio to 2.0.15 and 2.1.6 reflects the successMessage parameters. By this mean, a user accessing the Enduser UI could execute javascript code from URL query string.
Why it matters now
EPSS 0.0123 69th percentileScored 2026-11-07
Fix Fixed org.apache.syncope.client:syncope-client-enduser (Maven): 2.0.15, 2.1.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Apache Syncope | Apache Syncope 2.0.X releases prior to 2.0.15, 2.1.X releases prior to 2.1.6 | — | No fix listed | CNA |
| — | org.apache.syncope.client:syncope-client-enduser (Maven) | before 2.0.15 | 2.0.15 | Patch available | GHSA-6qj8-c27w-rp33 |
| — | org.apache.syncope.client:syncope-client-enduser (Maven) | 2.1.0 to before 2.1.6 | 2.1.6 | Patch available | GHSA-6qj8-c27w-rp33 |
- Apache Syncope Vendor— Affected Apache Syncope 2.0.X releases prior to 2.0.15, 2.1.X releases prior to 2.1.6 Fixed in — No fix listed CNA
- org.apache.syncope.client:syncope-client-enduser (Maven) Vendor— Affected before 2.0.15 Fixed in 2.0.15 Patch available GHSA-6qj8-c27w-rp33
- org.apache.syncope.client:syncope-client-enduser (Maven) Vendor— Affected 2.1.0 to before 2.1.6 Fixed in 2.1.6 Patch available GHSA-6qj8-c27w-rp33
Remediation
- Fix · GHSA-6qj8-c27w-rp33 org.apache.syncope.client:syncope-client-enduser (Maven) Fixed in 2.0.15 Advisory →
- Fix · GHSA-6qj8-c27w-rp33 org.apache.syncope.client:syncope-client-enduser (Maven) Fixed in 2.1.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-17557
- 2026-10-03 Alias added: GHSA-6qj8-c27w-rp33
References
More Apache Syncope vulnerabilities
- TI-2025-35632 Apache Syncope: Remote Code Execution by delegated administrators CVSS 3.1HIGH 7.2
- TI-2026-38503 Apache Syncope: Remote Code Execution via Scripted Connector CVSS 3.1CRITICAL 9.8
- TI-2026-45025 Apache Syncope: RCE via Groovy Sandbox bypass CVSS 3.1CRITICAL 9.8
- TI-2026-44406 Apache Syncope: User self-service privilege escalation CVSS 3.1CRITICAL 9.8
- TI-2026-41245 Apache Syncope: SQL injection vulnerability in Audit Events search CVSS 3.1CRITICAL 9.8
- TI-2026-38491 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-17557 · CVE Program
- CVE-2019-17557 · NVD
- FIRST EPSS
- GHSA-6qj8-c27w-rp33 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences