Read the docs
TI-2019-14377 Aliases CVE-2019-19935GHSA-h236-g5gh-vq6c

Froala Editor before 3.2.3 allows XSS.

Priority LOW 31CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Froala Editor before 3.2.3 allows XSS.

Why it matters now

EPSS 0.01847 79th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed froala-editor (npm): 3.2.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—froala-editor (npm)before 3.2.33.2.3Patch availableGHSA-h236-g5gh-vq6c
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • froala-editor (npm) Vendor— Affected before 3.2.3 Fixed in 3.2.3 Patch available GHSA-h236-g5gh-vq6c

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:froala:froala_editor:*:*:*:*:*:*:*:*before 3.2.3VulnerableFroala
  • cpe:2.3:a:froala:froala_editor:*:*:*:*:*:*:*:* Versions before 3.2.3 Vulnerable ·Froala

Remediation

  • Fix · GHSA-h236-g5gh-vq6c froala-editor (npm) Fixed in 3.2.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-19935
  2. 2026-10-03 Alias added: GHSA-h236-g5gh-vq6c

References

  • TI-2023-22596 Cross-site scripting (XSS) vulnerability in Froala Froala Editor v.4.1.1 allows remote… CVSS 3.1MEDIUM 6.1
  • TI-2023-22039 Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability. CVSS 3.1MEDIUM 5.4
  • TI-2021-09350 Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing. CVSS 3.1MEDIUM 5.4
  • TI-2021-10659 Froala Editor 3.2.6 is affected by Cross Site Scripting (XSS). CVSS 3.1MEDIUM 6.1
  • TI-2023-23161 A Cross-site scripting (XSS) vulnerability in Froala Editor v.4.1.1 allows attackers to… CVSS 3.1MEDIUM 6.1
  • TI-2020-14412 A cross site scripting (XSS) vulnerability in the Insert Video function of Froala WYSIWYG… CVSS 3.1MEDIUM 6.1
See all 7 →

Sources