Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01038 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed froala/wysiwyg-editor (Packagist): 4.1.4froala-editor (npm): 4.1.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | froala/wysiwyg-editor (Packagist) | 4.0.1 to before 4.1.4 | 4.1.4 | Patch available | GHSA-hvpq-7vcc-5hj5 |
| — | froala-editor (npm) | 4.0.1 to before 4.1.4 | 4.1.4 | Patch available | GHSA-hvpq-7vcc-5hj5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- froala/wysiwyg-editor (Packagist) Vendor— Affected 4.0.1 to before 4.1.4 Fixed in 4.1.4 Patch available GHSA-hvpq-7vcc-5hj5
- froala-editor (npm) Vendor— Affected 4.0.1 to before 4.1.4 Fixed in 4.1.4 Patch available GHSA-hvpq-7vcc-5hj5
Remediation
- Fix · GHSA-hvpq-7vcc-5hj5 froala/wysiwyg-editor (Packagist) Fixed in 4.1.4 Advisory →
- Fix · GHSA-hvpq-7vcc-5hj5 froala-editor (npm) Fixed in 4.1.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-41592
- 2026-10-03 Alias added: GHSA-hvpq-7vcc-5hj5
References
Advisory 3
More Froala Editor vulnerabilities
- TI-2023-22596 Cross-site scripting (XSS) vulnerability in Froala Froala Editor v.4.1.1 allows remote… CVSS 3.1MEDIUM 6.1
- TI-2021-09350 Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing. CVSS 3.1MEDIUM 5.4
- TI-2019-14377 Froala Editor before 3.2.3 allows XSS. CVSS 3.1MEDIUM 6.1
- TI-2021-10659 Froala Editor 3.2.6 is affected by Cross Site Scripting (XSS). CVSS 3.1MEDIUM 6.1
- TI-2023-23161 A Cross-site scripting (XSS) vulnerability in Froala Editor v.4.1.1 allows attackers to… CVSS 3.1MEDIUM 6.1
- TI-2020-14412 A cross site scripting (XSS) vulnerability in the Insert Video function of Froala WYSIWYG… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-41592 · CVE Program
- CVE-2023-41592 · NVD
- FIRST EPSS
- GHSA-hvpq-7vcc-5hj5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences