A cross site scripting (XSS) vulnerability in the Insert Video function of Froala WYSIWYG…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A cross site scripting (XSS) vulnerability in the Insert Video function of Froala WYSIWYG Editor 3.1.0 allows attackers to execute arbitrary web scripts or HTML.
Why it matters now
EPSS 0.00868 58th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed froala-editor (npm): 4.0.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | froala-editor (npm) | before 4.0.11 | 4.0.11 | Patch available | GHSA-97x5-cc53-cv4v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- froala-editor (npm) Vendor— Affected before 4.0.11 Fixed in 4.0.11 Patch available GHSA-97x5-cc53-cv4v
Remediation
- Fix · GHSA-97x5-cc53-cv4v froala-editor (npm) Fixed in 4.0.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-22864
- 2026-10-03 Alias added: GHSA-97x5-cc53-cv4v
References
Exploit 2
More Froala Editor vulnerabilities
- TI-2023-22596 Cross-site scripting (XSS) vulnerability in Froala Froala Editor v.4.1.1 allows remote… CVSS 3.1MEDIUM 6.1
- TI-2023-22039 Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability. CVSS 3.1MEDIUM 5.4
- TI-2021-09350 Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing. CVSS 3.1MEDIUM 5.4
- TI-2019-14377 Froala Editor before 3.2.3 allows XSS. CVSS 3.1MEDIUM 6.1
- TI-2021-10659 Froala Editor 3.2.6 is affected by Cross Site Scripting (XSS). CVSS 3.1MEDIUM 6.1
- TI-2023-23161 A Cross-site scripting (XSS) vulnerability in Froala Editor v.4.1.1 allows attackers to… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-22864 · CVE Program
- CVE-2020-22864 · NVD
- FIRST EPSS
- GHSA-97x5-cc53-cv4v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences