Read the docs

A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in…

Priority HIGH 80Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 fixed, 8 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in src/main/java/org/jenkinsci/plugins/workflow/cps/CpsFlowDefinition.java, src/main/java/org/jenkinsci/plugins/workflow/cps/CpsGroovyShellFactory.java that allows attackers with Overall/Read permission to provide a pipeline script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.

Why it matters now

EPSS 0.86054 99th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD and the CNA
Fix Partial org.jenkins-ci.plugins.workflow:workflow-cps-parent (Maven): 2.61.1org.jenkins-ci.plugins:pipeline-model-definition (Maven): 1.3.4.1+1 more productRed Hat: 1 fixed, 8 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsPipeline: Groovy Pluginup to 2.61—No fix listedCNA
—org.jenkins-ci.plugins.workflow:workflow-cps-parent (Maven)before 2.61.12.61.1Patch availableGHSA-6q78-6xvr-26fg
—org.jenkins-ci.plugins:pipeline-model-definition (Maven)before 1.3.4.11.3.4.1Patch availableGHSA-6q78-6xvr-26fg
—org.jenkins-ci.plugins:script-security (Maven)before 1.501.50Patch availableGHSA-6q78-6xvr-26fg
  • Pipeline: Groovy Plugin VendorJenkins Affected up to 2.61 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins.workflow:workflow-cps-parent (Maven) Vendor— Affected before 2.61.1 Fixed in 2.61.1 Patch available GHSA-6q78-6xvr-26fg
  • org.jenkins-ci.plugins:pipeline-model-definition (Maven) Vendor— Affected before 1.3.4.1 Fixed in 1.3.4.1 Patch available GHSA-6q78-6xvr-26fg
  • org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.50 Fixed in 1.50 Patch available GHSA-6q78-6xvr-26fg

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:pipeline\:_groovy:*:*:*:*:*:jenkins:*:*_groovyVulnerableJenkins
cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:*3.11VulnerableRed Hat
  • cpe:2.3:a:jenkins:pipeline\:_groovy:*:*:*:*:*:jenkins:*:* Versions _groovy Vulnerable ·Jenkins
  • cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* Versions 3.11 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-6q78-6xvr-26fg org.jenkins-ci.plugins.workflow:workflow-cps-parent (Maven) Fixed in 2.61.1 Advisory →
  • Fix · GHSA-6q78-6xvr-26fg org.jenkins-ci.plugins:pipeline-model-definition (Maven) Fixed in 1.3.4.1 Advisory →
  • Fix · GHSA-6q78-6xvr-26fg org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.50 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.10AffectedNo fix yet
Red Hat OpenShift Container Platform 3.2AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.3AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.4AffectedNo fix yet
Red Hat OpenShift Container Platform 3.5AffectedNo fix yet
Red Hat OpenShift Container Platform 3.6AffectedNo fix yet
Red Hat OpenShift Container Platform 3.7AffectedNo fix yet
Red Hat OpenShift Container Platform 3.9AffectedNo fix yet
Red Hat OpenShift Container Platform 3.11Fixed—
Not affected: 1 product
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1003001
  2. 2026-10-03 Alias added: GHSA-6q78-6xvr-26fg

References

  • TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-15847 A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier… CVSS 3.1HIGH 8.8
  • TI-2023-11034 Cross-site scripting in Jenkins Pipeline: Build Step Plugin CVSS 3.1MEDIUM 5.4
  • TI-2019-15886 A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows… CVSS 3.1CRITICAL 9.8
  • TI-2022-21197 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin CVSS 3.1CRITICAL 9.9
  • TI-2022-08895 Protection mechanism failure in Jenkins Pipeline: Shared Groovy Libraries Plugin CVSS 3.1HIGH 8.8
See all 39 →

Sources